hdu 4300 Clairewd’s message(扩展KMP)

Problem Description

Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

Input

The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;

Output

For each test case, output one line contains the shorest possible complete text.

Sample Input

2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde

Sample Output

abcdabcd
qwertabcde

Author

BUPT

Source

2012 Multi-University Training Contest 1


题意:

首先有一个字母的转换表,就是输入的第一行的字符串,就是'a'转成第一个字母,'b'转成转换表的第二个字母·······
然后下面一个字符串是密文+明文的形式的字符串。
就是说前后两段是重复的,只不过通过转换表转换了下。
而且后面一段可能不完整。
让我们补完整。
并且补加的字符最少;

思路:  扩展KMP,用C1表示全是密文;C2表示全是明文;然后用C2去匹配C1;求出最大后缀(最大后缀需要自己去设置条件),处理一下就得到结果;
  代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=100005;
char c[26];
int nex[N];
int vis[26];  //记录给出的转换表的字母所在位置
int ex[N];
void getnext(char *c)
{
    int len=strlen(c);
    int i=0;
    nex[0]=len;
    while(c[i]==c[i+1]&&i<len-1)
        i++;
    nex[1]=i;
    int po=1;
    for(int i=2;i<len;i++)
    {
        if(nex[i-po]+i<nex[po]+po)
            nex[i]=nex[i-po];
        else
        {
            int j=nex[po]+po-i;
            if(j<0) j=0;
            while(i+j<len&&c[i+j]==c[j])
                j++;
            nex[i]=j;
            po=i;
        }
    }
}
void ekmp(char *c1,char *c2)
{
    getnext(c2);
    int len1=strlen(c1),len2=strlen(c2);
    int i=0;
    while(c1[i]==c2[i]&&i<len1&&i<len2)
        i++;
    ex[0]=i;
    int po=0;
    for(int i=1;i<len1;i++)
    {
        if(nex[i-po]+i<ex[po]+po)
            ex[i]=nex[i-po];
        else
        {
            int j=ex[po]+po-i;
            if(j<0) j=0;
            while(i+j<len1&&c1[i+j]==c2[j])
                j++;
            ex[i]=j;
            po=i;
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    char c1[N],c2[N];
    while(t--)
    {
        scanf("%s",c);
        memset(c2,NULL,sizeof(c2));
        for(int i=0;i<26;i++)
            vis[c[i]-'a']=i;
        scanf("%s",c1);
        int len=strlen(c1);
        for(int i=0;i<len;i++)
            c2[i]=c[c1[i]-'a'];
        ekmp(c2,c1);
        int s,k;
        if(len%2)  //只能从原串的后一半开始查找,因为密文是全部已知的,明文少于密文;
            k=len/2+1;
        else
            k=len/2;
        for(;k<len;k++)
        {
            if(ex[k]==len-k)  //划分为的两部分加起来len;
            {
                s=ex[k];
                break;
            }
        }
        printf("%s",c1);
        if(k==len)
        {
            for(int i=0;i<len;i++)
                printf("%c",vis[c1[i]-'a']+'a');
            printf("\n");
            continue;
        }
        for(int i=s;i<len-s;i++)
            {
                printf("%c",vis[c1[i]-'a']+'a');
            }
        printf("\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值