hdu 3678 Katu Puzzle (2-sat)

Description

Katu Puzzle is presented as a directed graph G(VE) with each edge e(a, b) labeled by a boolean operator op (one of AND, OR, XOR) and an integer c (0 ≤ c ≤ 1). One Katu is solvable if one can find each vertex Vi a value Xi (0 ≤ X≤ 1) such that for each edge e(a, b) labeled by op and c, the following formula holds:

 Xa op Xb = c

The calculating rules are:

AND01
000
101
OR01
001
111
XOR01
001
110

Given a Katu Puzzle, your task is to determine whether it is solvable.

Input

The first line contains two integers N (1 ≤ N ≤ 1000) and M,(0 ≤ M ≤ 1,000,000) indicating the number of vertices and edges.
The following M lines contain three integers (0 ≤ a < N), b(0 ≤ b < N), c and an operator op each, describing the edges.

Output

Output a line containing "YES" or "NO".

Sample Input

4 4
0 1 1 AND
1 2 1 OR
3 2 0 AND
3 0 0 XOR

Sample Output

YES

Hint

X 0 = 1,  X 1 = 1,  X 2 = 0,  X 3 = 1.

Source

POJ Founder Monthly Contest – 2008.07.27, Dagger


题意:有一个大小为N的集合={x1,x2..xn},xi=0或1,现在给出它们之间的一些逻辑运算的结果(比如x1 and x2=1),逻辑运算有AND OR XOR三种,问是否存在一种满足所有条件的取值方案。


思路:

   每一位选择0或1两种状态,我们可以联想到2-sat;

   对于建图还是挺简单的;

    最近学会用两种2-sat算法;

  第一种是TARJAN算法判强断联通分量求解,个人觉得局限性大;

 第二种的话是搜索染色的方法,如果题目要输出方案,这种方法能够解决,并且输出字典序最小的结果;


下面用染色的方法做的;


代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=5005;
const int M=4000005;
struct node{
    int now,next;
}str[M];
int head[N],tot,top;
int vis[N],a[N];
int select(char s[])
{
    if(s[0]=='A')
        return 0;
    else if(s[0]=='O')
        return 1;
    else
        return 2;
}
void add(int x,int y)
{
    str[tot].now=y;
    str[tot].next=head[x];
    head[x]=tot++;
}
bool dfs(int u,int n)
{
    if(vis[u+n]) return false;
    if(vis[u]) return true;
    a[top++]=u;
    vis[u]=1;
    for(int i=head[u];i!=-1;i=str[i].next)
    {
        int v=str[i].now;
        if(!dfs(v,n)) return false;
    }
    return true;
}
bool ok(int n)
{
    memset(vis,0,sizeof(vis));
    for(int i=0;i<n;i++)
    {
        if(!vis[i]&&!vis[i+n])
        {
            top=0;
            if(!dfs(i,n))
            {
                while(top)
                    vis[a[--top]]=0;
                if(!dfs(i+n,n))
                    return false;
            }
        }
    }
    return true;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        tot=0;
        memset(head,-1,sizeof(head));
        for(int i=0;i<m;i++)
        {
            int a,b,c;
            char s[5];
            scanf("%d%d%d%s",&a,&b,&c,s);
            if(select(s)==0)
            {
                if(c)
                {
                    add(a+n,b+n);
                    add(b+n,a+n);
                    add(a,a+n);
                    add(b,b+n);
                }
                else
                {
                    add(a+n,b);
                    add(b+n,a);
                }
            }
            else if(select(s)==1)
            {
                if(c)
                {
                    add(a,b+n);
                    add(b,a+n);
                }
                else
                {
                    add(a,b);
                    add(b,a);
                    add(a+n,a);
                    add(b+n,b);
                }
            }
            else
            {
                if(c)
                {
                    add(a,b+n);
                    add(b,a+n);
                    add(a+n,b);
                    add(b+n,a);
                }
                else
                {
                    add(a,b);
                    add(b,a);
                    add(a+n,b+n);
                    add(b+n,a+n);
                }
            }
        }
        if(ok(n))
            printf("YES\n");
        else
            printf("NO\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值