骑士精神 ← IDA*

【题目来源】
https://www.acwing.com/problem/content/description/197/
https://www.luogu.com.cn/problem/P2324

【题目描述】
在一个 5×5 的棋盘上有 12 个白色的骑士和 12 个黑色的骑士,且有一个空位。
在任何时候一个骑士都能按照骑士的走法(它可以走到和它横坐标相差为 1,纵坐标相差为 2 或者横坐标相差为 2,纵坐标相差为 1 的格子)移动到空位上。
给定一个初始的棋盘,怎样才能经过移动变成如下目标棋盘:为了体现出骑士精神,他们必须以最少的步数完成任务。

 【输入格式】
第一行有一个正整数 T,表示一共有 T 组数据。
接下来有 T 个 5×5 的矩阵,0 表示白色骑士,1 表示黑色骑士,* 表示空位。
两组数据之间没有空行。

【输出格式】
每组数据输出占一行。
如果能在 15 步以内(包括 15 步)到达目标状态,则输出步数,否则输出 −1。


【数据范围】
1≤T≤10

【输入样例】
2
10110
01*11
10111
01001
00000
01011
110*1
01110
01010
00100


【输出样例】
7
-1

【算法代码】

#include <bits/stdc++.h>
using namespace std;

int n;
int a[5][5];
int dx[]= {1,-1,-1,1,2,-2,-2,2};
int dy[]= {2,-2,2,-2,1,-1,1,-1};

//black:-1 white:1 void:0
int goal[5][5]= {
	-1,-1,-1,-1,-1,
	1,-1,-1,-1,-1,
	1,1,0,-1,-1,
	1,1,1,1,-1,
	1,1,1,1,1
};

int h() { //evaluation function
	int res=0;
	for(int i=0; i<5; i++)
		for(int j=0; j<5; j++)
			if(a[i][j] && a[i][j]!=goal[i][j]) res++;
	return res;
}

bool check(int x, int y) { //Determine if cross the line
	if(x<0||x>=5||y<0||y>=5) return false;
	return true;
}

bool dfs(int cur,int x,int y,int dep) {
	if(!h()) return true;
	if(cur+h()>dep) return false;

	for(int i=0; i<8; i++) {
		int tx=x+dx[i];
		int ty=y+dy[i];
		if(!check(tx,ty)) continue;

		swap(a[x][y],a[tx][ty]);
		if(dfs(cur+1,tx,ty,dep)) return true;
		swap(a[x][y],a[tx][ty]);
	}
	return false;
}

int main() {
	int T;
	cin>>T;
	while(T--) {
		int x,y;
		for(int i=0; i<5; i++)
			for(int j=0; j<5; j++) {
				char c;
				cin>>c;
				if(c=='0') a[i][j]=1;
				else if(c=='1') a[i][j]=-1;
				else a[i][j]=0,x=i,y=j;
			}

		bool flag=1;
		for(int maxd=0; maxd<=15; maxd++) {
			if(dfs(0,x,y,maxd)) {
				cout<<maxd<<endl;
				flag=0;
				break;
			}
		}

		if(flag) cout<<-1<<endl;
	}

	return 0;
}


/*
in:
2
10110
01*11
10111
01001
00000
01011
110*1
01110
01010
00100

out:
7
-1
*/

【参考文献】
https://www.acwing.com/solution/content/8733/
https://www.codenong.com/p12110852/
https://blog.csdn.net/wl7777777777/article/details/124259366


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值