J - Labyrinth 树的直径的应用

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended. 
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc

 

题目大意

     找出以   “   .   ”   (点) 构成的两点之间距离的最大值,

思路

      利用树的直径的思想,先任意选择一位置(点)为起点,用bfs求出与它距离最大的点的位置,再用该点为起点,用bfs,所求的与它距离最大的点,一定是矩阵中两点距离最远的点。(不懂得可以查询了解一下树的直径的定义)

 

1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
#include <iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<cstring>
#include<cstdio>
using namespace std;

const int MAXN=1e3+10;
char s[MAXN][MAXN];
int n,m; // n 是 行 , m 是列
int vis[MAXN][MAXN];  // 标记是否访问

struct node
{
    int x,y;
    int step;   // 距离
    friend bool operator < (node a,node b)
    {
        return a.step<b.step;
    }
};
int d[4][2]={0,1,0,-1,1,0,-1,0};
node bfs(int x,int y)
{
    priority_queue<node> que;
    node e1,e2;
    e1.x=x;e1.y=y;e1.step=0;
    que.push(e1);
    vis[x][y]=1;
    node point;
    point.x=x;point.y=y;point.step=0;
    while(que.size()){
        e1=que.top();que.pop(); 
        if(point.step<e1.step){    //  取最大值
            point=e1;     
        }
        for(int i=0;i<4;i++){
            e2.x=e1.x+d[i][0];
            e2.y=e1.y+d[i][1];
            if(e2.x>=0&&e2.x<n&&e2.y>=0&&e2.y<m
               &&s[e2.x][e2.y]=='.'&&vis[e2.x][e2.y]==0){
                    vis[e2.x][e2.y]=1;
                    e2.step=e1.step+1;
                    que.push(e2);
               }
        }
    }
    return point;   // 返回最远位置的坐标
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&m,&n);
        for(i=0;i<n;i++)
            scanf("%s",s[i]);
        memset(vis,0,sizeof(vis));
        node q;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)       // 任选一点为起点,求出距离最远的点的坐标
                if(s[i][j]=='.'&&vis[i][j]==0){ 
                    q=bfs(i,j);
                }
        memset(vis,0,sizeof(vis));
        q=bfs(q.x,q.y);         // 再次利用bfs,求出距离最大值
        printf("Maximum rope length is %d.\n",q.step);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值