POJ 1611 The Suspects 并查集(代码带启发式合并)

<div class="ptt" lang="en-US" style="text-align: center; font-size: 18pt; font-weight: bold; color: blue;">The Suspects</div><div class="plm" style="text-align: center;font-size:14px;"><table align="center"><tbody><tr><td><strong>Time Limit:</strong> 1000MS</td><td width="10px"> </td><td><strong>Memory Limit:</strong> 20000K</td></tr><tr><td><strong>Total Submissions:</strong> 23213</td><td width="10px"> </td><td><strong>Accepted:</strong> 11268</td></tr></tbody></table></div><p class="pst" style="font-size: 18pt; font-weight: bold; color: blue;">Description</p><div class="ptx" lang="en-US" style="font-family: 'Times New Roman', Times, serif;font-size:14px;">Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.</div><p class="pst" style="font-size: 18pt; font-weight: bold; color: blue;">Input</p><div class="ptx" lang="en-US" style="font-family: 'Times New Roman', Times, serif;font-size:14px;">The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.</div><p class="pst" style="font-size: 18pt; font-weight: bold; color: blue;">Output</p><div class="ptx" lang="en-US" style="font-family: 'Times New Roman', Times, serif;font-size:14px;">For each case, output the number of suspects in one line.</div><p class="pst" style="font-size: 18pt; font-weight: bold; color: blue;">Sample Input</p><pre class="sio" style="font-family: 'Courier New', Courier, monospace;font-size:14px;">100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source


 
<strong><span style="font-size:24px;">并查集模板题,带启发式合并、路径压缩</span></strong>
<strong><span style="font-size:24px;">把同一社团中的所有成员并成一个集合,加入多个社团的人会使这些社团合为一个集合</span></strong>
<strong><span style="font-size:24px;">这样输出0所在集合的元素个数即可。</span></strong>
<strong><span style="font-size:24px;">因为要记录元素个数,顺便将代码加入启发式合并</span></strong>
<strong><span style="font-size:24px;">
</span></strong>
<pre name="code" class="cpp"><pre name="code" class="cpp">#include<cstdio>
#include<cstring>

const int MAX = 30000 + 100;
int fa[MAX];

int Find(int x){
    return fa[x] < 0 ? x : fa[x] = Find(fa[x]);///根的fa[]值小于0
}

void Union(int x,int y){
    int a = Find(x),b = Find(y);
    if(a == b)
        return;
    ///启发式合并,判断哪个集合的元素多,将元素少的合并到元素多的集合上去
    ///根节点的fa[]值的绝对值即为集合中元素个数
    if(fa[a] > fa[b]){///注意值为负,大的绝对值小
        fa[b] += fa[a];
        fa[a] = b;
    } else {
        fa[a] += fa[b];
        fa[b] = a;
    }
}

int main(void) {
    int m,n;
    while(~scanf("%d%d",&n,&m) && (m || n)){
        memset(fa,-1,sizeof(int) * n);///fa[]数组全部初始化为-1,即元素个数为1的根
        for(int i = 0;i < m;++i){
            int k;
            scanf("%d",&k);
            if(k > 0){
                int x,y;
                scanf("%d",&x);
                for(int i = 1;i < k;++i){
                    scanf("%d",&y);
                    Union(x,y);
                }
            }
        }
        printf("%d\n",-fa[Find(0)]);
    }
    return 0;
}


 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值