HDU2199 二分查找(浮点型) 水题

Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16056    Accepted Submission(s): 7115


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input

2
100
-4



Sample Output

1.6152
No solution!



Author
Redow


Recommend
lcy


Statistic | Submit | Discuss | Note
#include<stdio.h>
#include<math.h>
double C(double n)
{
    return 8*n*n*n*n+7*n*n*n+2*n*n+3*n+6;
}
double Binsrch(double k)
{
    if(C(0)>k||C(100)<k) return -99;
    double low=0,high=100,mid;
    while(high-low>1e-9)
    {
        mid=(low+high)/2;
        if(C(mid)>(double)k) high=mid;
        else   low=mid;
    }
    return mid;
}
int main(void)
{
    int T;
   // printf("%.10lf\n",1e-9);
    while(~scanf("%d",&T))
    {
        for(;T>0;T--)
        {
            double n;scanf("%lf",&n);
            double L=Binsrch(n);
            if(L!=-99) printf("%.4lf\n",L);
            else printf("No solution!\n");
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值