Hduoj4190【二分】

/*Distributing Ballot Boxes 
Time Limit : 20000/10000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 0   Accepted Submission(s) : 0
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single 
resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. 
You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of 
boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the 
lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the 
box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned 
to vote in one box.
In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to 
vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities
 and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded 
 of all in the optimal assignment. 
Input
The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot 
boxes. Each of the following N lines contains an integer ai,(1<=ai<=5,000,000), indicating the population of the ith city. 
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed. 
Output
For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment. 
Sample Input
2 7
200000
500000

4 6
120
2680
3400
200

-1 -1
Sample Output
100000
1700
Source
SWERC 2011 
*/
#include<stdio.h>
#include<string.h>
int city[500050], n, m;
int main()
{
	int i, j, k, max;
	while(scanf("%d%d", &n, &m) != EOF && (n != -1 || m != -1))
	{
		max = 0;
		for(i = 1; i <= n; ++i)
		{
			scanf("%d", &city[i]);
			if(city[i] > max)
			max = city[i];
		}
		int l = 0, r = max, mid;
		while(l <= r)
		{
			mid = (l+r) / 2;
			k = 0;
			for(i = 1; i <= n; ++i)
			{
				k += city[i] / mid;
				if(city[i] % mid != 0)
				++k;
			}
			if(k > m)
				l = mid+1;
			else
				r = mid-1;
		}
		printf("%d\n", l);
	}
	return 0;
}


题意:现在有n个城市,每个城市都有一定的人数,现在开始选举投票,每个人可以投一票,并且将票放入盒子中,现在有m个盒子,需要分配给n个城市,每个城市最少一个盒子,现在求怎样分配盒子能使得盒子中的最大票数最小。

思路:常规的思路就是先将n个城市每个都分配一个盒子,对于剩下的盒子则进行一个一个分配,即哪个城市的盒子的最大票数最大,则多分配一个盒子,接着将总票数均分到盒子中,更新了盒子的最大票数,直至盒子个数分配完毕,则最终的盒子中最大的票数即为答案。但是此题盒子个数非常大,所以必然会超时。那么正确的思路则是从反面考虑的,即将最终的答案作为已知的,然后逆着来寻找。假设最终的最大盒子票数是已知的,那么无论哪个盒子中的票数都不会比这个大,那么我们可以用二分法从0~输入数据中的最大值开始寻找答案,对于一个确定的数来说,若将其分成2堆,想要得到最小的堆票数,那么必定是平分一半,所以二分的原理就在这,即不断的将0~最大上限进行二分,每分一次就检验当前的中间值mid作为最大盒子票数后所能得到的盒子数,看看是否和题目所给相同,若相同则能获得与答案相近的一个区间,对于最终答案的上限进行不断缩小,直至区间长度缩为1获得最小的盒子最大数。

难点:此题的难点就在于找到解题思路,很难想到用这个方法来逼近最终的答案。。

体会:对于这种题目实在是不知道该从何下手~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值