UVA 424

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

n个大数相加,把C提前初始化并确保最后检索0输出

#include <bits/stdc++.h>
using namespace std;
#define MAXN 100
#define MAXN_E 500000   //边可能很多
char A[100000], B[100000], C[100000];
void Cal(char *A, char *B, int lenA, int lenB)
{
    int add = 0;A[0] = 0;//进位
    for (int i = lenA, j = lenB;i>0;i--, j--)
    {
        int dia = A[i] - '0' + add;
        dia = i <= lenA - lenB ? dia : dia + B[j] - '0';
        C[i] = dia % 10 + '0';
        add = dia / 10;
    }
    C[0] = add ? '1' : '0';
}
void Scan(void)
{
    for(int i=0;i<=1000;i++) C[i] = '0';   //这步比较重要
    while(scanf("%s", A + 1))
    {
        if(A[1]=='0') break;
        int lena = strlen(A + 1), lenc = strlen(C + 1);
        lena > lenc ? Cal(A, C, lena, lenc) : Cal(C, A, lenc, lena);
    }
}
void Print(void)
{//除去前置0
    int k;for (k = 0;C[k] == '0';k++);
    printf("%s\n", C + k);
}
int main(void)
{
    //freopen("F:\\test.txt","r",stdin);
    Scan();Print();
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值