hdu2955 Robberies 灰常灰常好的背包

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3802    Accepted Submission(s): 1433


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

 

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05Sample Output
  
  
2
4
6
 
题意:输入一个数 表示一共多少组数据 输入一个浮点型数表示小偷被抓的几率不超过这个情况下能偷的最多钱 输入一个整形表示多少个银行
输入3组数据 一组2个数 分别是该银行的钱 以及被抓的几率
求小偷不被抓的情况下能偷的最多钱
 
思路: 一开始我是让几率当背包 然后钱做val 但是 这样是错误的 因为几率是浮点型 虽然可以*100变成整形 但是 几率是相乘得出的 而几率当背包无法模拟几率的相乘 由题中数据看 仿佛用几率当背包 然后几率相加 能得到样例中的结果 但是这是错误的思想
几率哪有加的啊
所以就要变通一下 把钱当背包 看总共多少钱 把几率当价值
 
#include<stdio.h> #include<string.h> double val[105],x; int wei[105]; double bag[10500000]; void _01bag(int v,int m) {      int i,j;   for(i=0;i<v+3;i++)    bag[i]=0;   bag[0]=1;       for(i=0;i<m;i++)     for(j=v;j>=wei[i];j--)      if(bag[j]<bag[j-wei[i]]*(1-val[i]))        bag[j]=bag[j-wei[i]]*(1-val[i]);  for(i=v;i>=0;i--)   if(bag[i]>=1-x) {printf("%d\n",i);break;}
    return; } int main() {  int t,i,m,v;     scanf("%d",&t);  while(t--)  {   v=0;   scanf("%lf %d",&x,&m);   for(i=0;i<m;i++)   {    scanf("%d %lf",&wei[i],&val[i]);    v=v+wei[i];   }   _01bag(v,m);  }  return 0; }
个人感觉下面的方法更好些
#include <iostream> 
#include <algorithm>
using namespace std;
int m[101];
double p[101],dp[10001];
int main()
{
    int t,n,i,j,sum;
    double P;
    cin >> t;
    while(t-- && cin >> P >> n)
    {
              sum = 0;
              P = 1 - P;
              for(i = 0;i < n;i++)
              {
                    cin >> m[i] >> p[i];
                    sum += m[i];
                    p[i] = 1 - p[i];
              }
              memset(dp,0,sizeof(dp));
              dp[0] = 1;
              for(i = 0;i < n;i++) 
                    for(j = sum;j >= m[i];j--)
                          if(dp[j] < dp[j-m[i]]*p[i])
                                   dp[j] = dp[j-m[i]]*p[i];
              for(i = sum;i >= 0&&dp[i] < P;i--); 
              cout << i << endl;
    }
    return 0;
}

此代码来自http://qianmacao.blog.163.com/blog/static/203397180201221510548987/
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值