hdu2955 Robberies 01背包变形

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28723    Accepted Submission(s): 10546


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the  lucrative (有利可图的) business of bank robbery only for a short while, before retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a  tolerable (可以的) probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
 
 
30.04 31 0.022 0.033 0.050.06 32 0.032 0.033 0.050.10 31 0.032 0.023 0.05
 

Sample Output
 
 
246
 

Source
#include<stdio.h>
#include<string.h> 
#include<iostream>
using namespace std;


int money[105];
float P,pos[105],dp[10050];
//类似hdu1203 I NEED A OFFER! 01背包 
//为什么不用成功抢劫概率当背包容量,首先概率是小数,其次概率不是直接相加的,而是相乘的 
int main()//用成功逃走的概率当做价值,银行的总钱数当做背包容量.
{
	int i,j,t,n;
	scanf("%d",&t);
	while(t--)
	{   
	    memset(dp,0,sizeof(dp));
		scanf("%f%d",&P,&n);
		P=1-P;//转换成安全概率要大于st 
		int sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%f",&money[i],&pos[i]);
			pos[i]=(1-pos[i]);
			sum+=money[i];
	    }
	    
		dp[0]=1;//未抢劫一分钱那么安全撤退的概率就为1
		for(i=1;i<=n;i++)//遍历所有方案 
			for(j=sum;j>=money[i];j--)//
				dp[j]=max(dp[j],dp[j-money[i]]*pos[i]);//这里的每次成功的概率需要进行乘法运算,因为是两次成功的概率所以是乘法
	
		for(i=sum;i>=0;i--)
			if(dp[i]>=P)
				break;//找出可以成功逃走并且逃走概率不超过警戒值的 
		printf("%d\n",i);
	}
	return 0;
 } 
 
 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值