hdu 4350 Card 规律题 多校联合赛事

Card

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 471    Accepted Submission(s): 294


Problem Description
Bearchild is playing a card game with himself. But first of all, he needs to shuffle the cards. His strategy is very simple: After putting all the cards into a single stack,
he takes out some cards in the middle, from the L-th to the R-th when counting from top to bottom, inclusive, and puts them on the top. He repeats this action again
and again for N times, and then he regards his cards as shuffled.

Given L,R and N, and the initial card stack, can you tell us what will the card stack be like after getting shuffled?
 

Input
First line contains an integer T(1 <= T <= 1000), which is the test cases.
For each test case, first line contains 52 numbers(all numbers are distinct and between 1 and 52), which is the card number of the stack, from top to bottom.
Then comes three numbers, they are N, L and R as described. (0<=N<=10 9, 1<=L<=R<=52)
 

Output
For each test case, output "Case #X:", X is the test number, followed by 52 numbers, which is the card number from the top to bottom.Note that you should output one and only
one blank before every number.
 

Sample Input
  
  
1 13 2 10 50 1 28 37 32 30 46 19 47 33 41 24 52 27 42 49 18 9 48 23 35 31 8 7 12 6 5 3 22 43 36 51 40 26 4 44 17 39 38 15 14 25 16 29 20 21 45 11 34 902908328 38 50
 

Sample Output
  
  
Case #1: 26 4 44 17 39 38 15 14 25 16 29 20 21 45 13 2 10 50 1 28 37 32 30 46 19 47 33 41 24 52 27 42 49 18 9 48 23 35 31 8 7 12 6 5 3 22 43 36 51 40 11 34
 

Author
elfness@UESTC_Oblivion

题意:一共52个数     输入n   left right   表示把从left  到right的数拿出来   拿出来放到数串的最前面    如此重复n边   问最后的串是什么 (n很大)



思路    由于n 很大    貌似应该有规律     这时候可以找一个短点的小串  比如1 2 3 4  5 6 7 8   对这个串进行操作  最后可以发现

把一个串中的 从left 到right  移动     每移动right次  就会还原    故可对n进行%right  后 暴力

 
#include<stdio.h>
int main()
{
	int cas,i,n,left,right,pos,k;
	int a[55],change[55];
	scanf("%d",&cas);
	for(k=1;k<=cas;k++)
	{
           for(i=1;i<=52;i++)
			   scanf("%d",&a[i]);
		   scanf("%d %d %d",&n,&left,&right);
		   n=n%right;
		   while(n--)
		   {
		         pos=0;
		         for(i=left;i<=right;i++)
				 {
                        change[++pos]=a[i];
				 }
				 for(i=1;i<left;i++)
					 change[++pos]=a[i];
				 for(i=right+1;i<=52;i++)
					 change[++pos]=a[i];
				 for(i=1;i<=52;i++)
					 a[i]=change[i];
		   }
          printf("Case #%d:",k);
		   for(i=1;i<=52;i++)
			   printf(" %d",a[i]);
		   printf("\n");
	}
	return 0;
	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值