hdu 3336 KMP之杭电next灵魂

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1803    Accepted Submission(s): 851


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
    
    
14abab
 
 
sample output
6
 
/*本题题意可以理解为 把串a的各个子串分别作为模式串 查找模式串在主串中出现的次数
我们可以把串a的next函数打印出来 然后对应子串的next也就是next函数中的一部分
所以就不用一个一个子串的去求子串的next函数了  
另外 我们可以发现当某个子串只在a中出现一次的时候 再往子串上加字符 即下个子串也一定是1
如aabcde  aabc在主串中出现一次 那aabcd肯定更加是1次
所以之后的全是1 就没必要继续调用KMP了 就可以节省很多时间 防止超时
*/
#include<stdio.h>
#include<string.h>
char  a[200005];
char  b[200005];
int next[200005],d,d2,cnt;
void get_next()
{
     int i=1,j=0;
  next[1]=0;
  while(i<=d)
  {
   if(j==0||a[i]==a[j]) {i++;j++;next[i]=j;}
   else j=next[j];
  }
}
int KMP(char *str)
{
      int i=1,j=1;
    while(i<=d)
    {
     if(j==0||b[j]==a[i]) 
     {
      i++;j++;
      if(j==d2+1)  {cnt++; j=1;}
     } 
     else j=next[j];
    }
    return cnt;
}
int main()
{
 int t,i,ans,k;
 scanf("%d",&t);
 while(t--)
 {
  ans=0;
  scanf("%d",&d);
  getchar();
         gets(a+1);
   get_next();
 //  for(i=1;i<=d;i++)
  //  printf("%d ",next[i+1]-1);
 //  printf("\n");
   d2=0;
        for(i=1;i<=d;i++)
  {
   cnt=0;
   b[i]=a[i];
   b[i+1]='\0';
   d2++;
   k=KMP(&b[1]);
  // printf("%d ",k);
   if(ans>10007) ans=ans%10007;
   else
   ans=ans+k;
   if(k==1)
   {
                   ans=(ans+(d-i))%10007;
       break;
   }
  }
     printf("%d\n",ans);
 }
 return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值