hdu1358 Period KMP之next函数灵魂 KMP的周期 周期 周期

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 964    Accepted Submission(s): 480


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 


 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 


 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 


 

Sample Input
  
  
3aaa12aabaabaabaab0
 


 

Sample Output
  
  
Test case #12 23 3Test case #22 26 29 312 4

 

意思是,从第1个字母到第2字母组成的字符串可由某一周期性的字串(“a”)

的两次组成,也就是aa有两个a组成;

第三行自然就是aabaab可有两个aab组成;

第四行aabaabaab可由三个aab组成;

第五行aabaabaabaab可有四个aab组成

题意: 一个字符串,从头到某个位置,字符串的前缀最多重复了多少次

 

#include<stdio.h>
#include<string.h>
int next[1000002],d;
char a[1000002];
void get_next()
{
	int i=1,j=0;
	next[1]=0;
	while(i<=d)
	{
		if(j==0||a[i]==a[j]) {i++;j++;next[i]=j;}
		else j=next[j];
	}
}
int main()
{
	int i,k,t=0,flag;
	while(1)
	{
		flag=1;
		memset(next,0,sizeof(next));
		scanf("%d",&d);
		if(d==0) return 0;
		scanf("%s",a+1);
		get_next();
		printf("Test case #%d\n",++t);
		// for(i=1;i<=d+1;i++)  printf("%d ",next[i]);
		// printf("\n");
		for(i=2;i<=d;i++)
		{
			k=i-(next[i+1]-1);
			/*next[i+1]-1是i+1之前的循环长度      用i一减就是剩下的长度 如果剩下的长度为一个重复串的长度
			则可以输出  否则不能输出 如 abcabcabc  next[10]-1=6 用i一减(等于从abcabcabc中把abcabcabc拿走) 
			剩下个3(即abc)  i是3的整数倍(长串的1到i的子串中是全由abc组成) 此时能输出
			next[9]-1=2 说明剩下的不够一个重复串 即不能被i整除  不能输出*/
			if(i!=k&&i%k==0)  printf("%d %d\n",i,i/k);//i==k是指循环长度为0 即没有循环
		}
		printf("\n");
	}
	return 0;
}
/*非优化的next数组的含义是:next[i]=k模式串下标为i的字符的前k-1个字符与开首的前k-1个字符相等
例如 aabaabaab   next[10]=7 表示下标为10之前的字符前6个字符 与开首的前6个字符相等 所以当匹配不成功时 不用回溯到下标为6的位置去继续匹配
*/

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值