[kuangbin专题] KMP HDU 1358 Period

题目链接

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

 

题目大意:给一个串,找前缀重复的部分和重复的次数

理解next数组的意义

void find(int len){
	int i=0,j=0;
	for(i=1;i<=len;i++){
		int x=i-next[i];
		if(i%x==0&&(i/x)>1){
			printf("%d %d\n",i,i/x);
		}
	}
	printf("\n");
}

find函数函数中 i%x==0的意义是 1-->i 的长度是 i-->next[i] 的长度的倍数

(i/x)>1的意义是排除某个部分循环节只重复一次的情况,就是排除i==x;

 

AC代码

#include <stdio.h>
#include <string.h>
char a[1000100];
int next[1000100];
void getnext(int len){
	int j=-1,i=0;
	next[0]=-1;
	while(i<len){
		if(j==-1||a[i]==a[j]){
			i++;j++;
			next[i]=j;
		}
		else j=next[j];
	}
}
void find(int len){
	int i=0,j=0;
	for(i=1;i<=len;i++){
		int x=i-next[i];
		if(i%x==0&&(i/x)>1){
			printf("%d %d\n",i,i/x);
		}
	}
	printf("\n");
}
int main(){
	int n;
	int xxx=1;
	while(scanf("%d",&n)){
		if(n==0) return 0;
		printf("Test case #%d\n",xxx++);
		scanf("%s",a);
		getnext(n);
		find(n);
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值