hdu 2585 Hotel 很好的递归模拟题

Hotel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 216    Accepted Submission(s): 128


Problem Description
Last year summer Max traveled to California for his vacation. He had a great time there: took many photos, visited famous universities, enjoyed beautiful beaches and tasted various delicious foods. It is such a good trip that Max plans to travel there one more time this year. Max is satisfied with the accommodation of the hotel he booked last year but he lost the card of that hotel and can not remember quite clearly what its name is. So Max searched
in the web for the information of hotels in California ans got piles of choice. Could you help Max pick out those that might be the right hotel?
 

Input
Input may consist of several test data sets. For each data set, it can be format as below: For the first line, there is one string consisting of '*','?'and 'a'-'z'characters.This string represents the hotel name that Max can remember.The '*'and '?'is wildcard characters. '*' matches zero or more lowercase character (s),and '?'matches only one lowercase character.

In the next line there is one integer n(1<=n<=300)representing the number of hotel Max found ,and then n lines follow.Each line contains one string of lowercase character(s),the name of the hotel.
The length of every string doesn't exceed 50.
 

Output
For each test set. just simply one integer in a line telling the number of hotel in the list whose matches the one Max remembered.
 

Sample Input
  
  
herbert 2 amazon herbert ?ert* 2 amazon herbert * 2 amazon anything herbert? 2 amazon herber
 

Sample Output
  
  
1 0 2 0
 

Source
 

Recommend
lcy
 
 
 
 
意义:  输入一个串 包含 * ? 和小写字母 其中 *代码任意0个或多个字符    ?代表任意一个字符
然后输入k  之后k个字符串 问这k个字符串中有多少个符合上面的串的格式的
 
思路:
由于除了*   其他的符号进行比较时都可以一步一步的向后移动  所以遇到*的时候把主串*号之后的 与 现查找串对应位置的所有前缀子串进行比较 只要有一个可以表示成功 则总的来说是可以表示成功的 
限于表达能力   直接看代码好一些
#include<stdio.h>
#include<iostream>
#include<string>
using namespace std;
int find(string a,string b)
{
	int i,j;
	for(i=0;i<a.length();i++)
	{
           if(a[i]=='*')
		   {
			    if(i==a.length()-1)
                        return true;
			   string c=a.substr(i+1);
                for(j=i;j<b.length();j++)
					if(find(c,b.substr(j)))  return 1;
		   }
		   else
		   {
			   if(i>=b.length()) return 0;
			   if(a[i]=='?')  continue;
			   if(a[i]!=b[i]) return 0;
		   }
	}
	return 1;
}
int main()
{
      int ans;
	  string a,b;
	  while(cin>>a)
	  {
		  int k;
          ans=0;
		  scanf("%d",&k);
		   while(k--)
		   {
		
			   cin>>b;
			   if(find(a,b)) ans+=1;
		   }
		   printf("%d\n",ans);
	  }
	  return 0;
}

思路主要来自于 http://2225377fjs.blog.163.com/blog/static/17462983720111277324151/   

fjs的博客       自己要努力额!!!

 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值