HDU 2585 Hotel

Problem Description
Last year summer Max traveled to California for his vacation. He had a great time there: took many photos, visited famous universities, enjoyed beautiful beaches and tasted various delicious foods. It is such a good trip that Max plans to travel there one more time this year. Max is satisfied with the accommodation of the hotel he booked last year but he lost the card of that hotel and can not remember quite clearly what its name is. So Max searched
in the web for the information of hotels in California ans got piles of choice. Could you help Max pick out those that might be the right hotel?
 

Input
Input may consist of several test data sets. For each data set, it can be format as below: For the first line, there is one string consisting of '*','?'and 'a'-'z'characters.This string represents the hotel name that Max can remember.The '*'and '?'is wildcard characters. '*' matches zero or more lowercase character (s),and '?'matches only one lowercase character.

In the next line there is one integer n(1<=n<=300)representing the number of hotel Max found ,and then n lines follow.Each line contains one string of lowercase character(s),the name of the hotel.
The length of every string doesn't exceed 50.
 

Output
For each test set. just simply one integer in a line telling the number of hotel in the list whose matches the one Max remembered.
 

Sample Input
  
  
herbert 2 amazon herbert ?ert* 2 amazon herbert * 2 amazon anything herbert? 2 amazon herber
 

Sample Output
  
  
1 0 2 0
 

Source

Solution

给出一个字符串,问下列字符串中与所给匹配的有几个,?匹配一个字母,*匹配0或多个字母。

一开始想使用暴力扫一遍就好啦,结果*号有些难处理。

模糊匹配的话是可以用简单dp来做的,f[i][j]代表前i个字符和前j个字符匹配,注意*的话是和后面的所有字符都匹配的

dp的key

f[0][0] = true;//初始化
  for (i = 1; i <= ls; ++i)
    for (j = 1; j <= lx; ++j)
    {
      if ((s[i-1] == x[j-1] || s[i-1] == '?') && f[i-1][j-1]) f[i][j] = true;
      if (s[i-1] == '*' && f[i-1][j-1])
      {
        for (k = j-1; k <= lx; ++k) f[i][k] = true;//可以匹配后面的所有,注意匹配0个的时候是j-1
        break;
      }
    }
后来参考他人的思路,可以用递归,这样比较好理解。

#include <cstdio>
#include <cstring>

char s[55], t[55];
int ls, lt;

bool check(int lens, int lent)
{
  if (lens == ls && lent == lt) return true;
  if (lens == ls || lent == lt) return false;
  if (s[lens] == '?' || s[lens] == t[lent]) return check(lens+1, lent+1);
  if (s[lens] == '*') for (int i = lent; i <= lt; ++i) if (check(lens+1, i)) return true;//往后看看是不是可以匹配
  return false;
}

int main()
{
  while (scanf("%s", s) != EOF)
  {
    ls = strlen(s);
    int n, c = 0;

    scanf("%d", &n);
    while (n--)
    {
      scanf("%s", t);
      lt = strlen(t);
      if (check(0, 0)) ++c;
    }
    printf("%d\n", c);
  }

  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值