poj 1222 关灯开灯问题 暴搜

EXTENDED LIGHTS OUT
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5472 Accepted: 3615

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source

 
 
题意: 输入cas  输入一个5*6的矩阵   对于某个灯 如过点一下就会由开变关 由关边开 
对于每个灯应该如何点击才会使得所有灯泡都是关掉的
 
思路: 注意一个灯只需点击1下 点击多下没有意义
我们只要暴力出第一行的点击方法  之后如果第一行还有没有关掉的就必须在下一行点击关掉它     所以只要暴力第一行即可 总共2的6次方 64种情况
 
反思: 一开始不敢去做  怕麻烦   还有就是一定要看样例 看样例怎么得到的 才能找到方法
#include<stdio.h>
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int c[10][10],a[10][10],b[10][10];
int solve(int n)
{
    int i,j,k;
    for(k=0;k<6;k++)
      if(n&1<<k)
            c[0][k]=1;
      else c[0][k]=0;
    //for(i=0;i<6;i++) printf("%d ",c[0][i]);
    //printf("\n");
    for(i=0;i<5;i++)
        for(j=0;j<6;j++) b[i][j]=a[i][j];
    for(i=0;i<6;i++)
    {
        if(c[0][i]==1)
        {
            b[0][i]=!b[0][i];
            for(int k=0;k<4;k++)
            {

                int x=0+dir[k][0];int y=i+dir[k][1];
                if(x>=0&&x<6&&y>=0&&y<6)
                {
                    b[x][y]=!b[x][y];
                }
            }
        }
    }
    //第一行处理完毕
    for(i=1;i<5;i++)
    {
        for(j=0;j<6;j++)
          if(b[i-1][j]==1)
          {
              c[i][j]=1;
              b[i][j]=!b[i][j];
              for(int k=0;k<4;k++)
              {

                int x=i+dir[k][0];int y=j+dir[k][1];
                if(x>=0&&x<6&&y>=0&&y<6)
                {
                    b[x][y]=!b[x][y];
                }
             }
          }
          else c[i][j]=0;
    }
    for(j=0;j<6;j++)
        if(b[4][j]==1) return 0;
    return 1;

}
void print(int cas)
{
    printf("PUZZLE #%d\n",cas);
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
            printf("%d ",c[i][j]);
        printf("%d\n",c[i][5]);
    }
}
int main()
{
    int cas,i,j,k;
    scanf("%d",&cas);
    for(k=1;k<=cas;k++)
    {
        for(i=0;i<5;i++)
            for(j=0;j<6;j++)
               scanf("%d",&a[i][j]);
        for(i=0;i<1<<6;i++)
        {
            if(solve(i))
            {
                print(k);
                  break;
            }
        }
    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值