hnust 最小生成树

最小生成树

时间限制: 1 Sec   内存限制: 128 MB
提交: 325   解决: 142
[ 提交][ 状态][ 讨论版]

题目描述

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

输入

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 500). The following lines contain the N x N conectivity matrix, where each element shows the distance from one farm to another. Logically, they are N lines of N space-separated integers. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem

输出

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

样例输入

6
0 6 1 5 100 100
6 0 5 100 3 100
1 5 0 5 6 4
5 100 5 0 100 2
100 3 6 100 0 6
100 100 4 2 6 0

样例输出

15

提示

题意简述:在n个城市之间铺设光缆,铺设光缆费用很高且各个城市之间铺设光缆的费用不同。设计目标是使这n个城市之间的任意2个城市都可以直接或间接通信,并且要使铺设光缆的费用最低。


解题思路:这样的问题是一个求最小生成树的问题。解决这个问题的方法就是在由n个城市结点和n(n-1)/2条费用不同的边构成的无向连通图中找出最小生成树。首选Prim算法,也可以用Kruskal算法。


样例的数据来源于教材图7.16,用邻接矩阵表示。


生词:


optical fiber   光缆


N x N conectivity matrix        N x N的邻接矩阵


space-separated integers  空格隔开的整数


the diagonal 对角线

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f
int map[100][100],n,ans;

void prim() {

    int vis[100];
    int i,j,next;
    int lowcost[100];
    ans=0;
    memset(vis,0,sizeof(vis));
    for(i=1; i<=n; i++)
        lowcost[i]=map[1][i];
    vis[1]=1;
    for(i=2; i<=n; i++) {
        int mini=inf;
        for(j=1; j<=n; j++) {
            if(!vis[j]&&lowcost[j]<mini) {
                mini=lowcost[j];
                next=j;

            }
        }
        ans+=mini;
        vis[next]=1;
        for(j=1; j<=n; j++) {
            if(!vis[j]&&lowcost[j]>map[next][j])
                lowcost[j]=map[next][j];
        }


    }
    printf("%d\n",ans);


}
int main() {
    int i,j;
    while(scanf("%d",&n)==1) {
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                scanf("%d",&map[i][j]);

        prim();
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值