POJ1258(最小生成树)

POJ1258(最小生成树)


Agri-Net

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
题意

给出一个数字n代表邻接矩阵的大小,随后给出邻接矩阵的值。输出最小生成树的权值。

思路

​ 类似于POJ1789,用Prim求解。

代码
import java.util.Scanner;
public class AgriNet {
  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
    while(sc.hasNext()){
      int n = sc.nextInt();
      int[][] graph = new int[n][n];
      for (int i = 0; i < n; i++) {
        for (int j = 0; j < n; j++) {
          graph[i][j] = sc.nextInt();
        }
      }
      int result = prim(graph, 0);
      System.out.println(result);
    }
  }

  public static int prim(int[][] graph, int startPoint) {
    int result = 0;

    int[] lowcost = new int[graph.length];
    int[] closest = new int[graph.length];
    int minDis = Integer.MAX_VALUE;

    for (int i = 0; i < lowcost.length; i++) {//lowcost和closest的初始值
      lowcost[i] = graph[startPoint][i];
      closest[i] = startPoint;
    }

    for (int i = 0; i < lowcost.length - 1; i++) {//除了startPoint之外的n-1个点
      minDis = Integer.MAX_VALUE;
      int index = startPoint;
      for (int j = 0; j < lowcost.length; j++) {
        if (lowcost[j] != 0 && lowcost[j] < minDis) {
          minDis = lowcost[j];
          index = j;
        }
      }
      result = result + minDis;
      lowcost[index] = 0;
      for (int j = 0; j < lowcost.length; j++) {//更新lowcost和closest
        if (graph[index][j] != 0 && graph[index][j] < lowcost[j]) {
          lowcost[j] = graph[index][j];
          closest[j] = index;
        }
      }
    }
    return result;
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值