水题 Hamburger String

http://openoj.awaysoft.com:8080/judge/contest/view.action?cid=224#problem/B

Description

BUG is a famous burger shop. Lots of costumers wait for burgers outside the burger every morning, because those hamburgers are so unforgettable.

 

Costumers stand in a queue, they come one by one, the latest one join into the end.

 

When a costumer(A) come to the end of the queue, if theres already someone(B), wearing the same color as him, people between them(including A and B, called Hamburger String) will be served.

Served people leave the queue immediately.

 

N people come one by one, given their colors, can you tell me how many Hamburger Strings are there? 

Input

The first line is an integer T(T<=100).

Each case has an integer N(N<=100) in the first line.

Then N positive integers(<=20) follow, each corresponds a kind of color.

1 for red, 2 for yellow, and so on.

Output

For each case output a single integer, indicating the number of Hamburger Strings are served.

Sample Input

3 1 1 2 2 2 10 1 2 3 4 3 1 2 4 1 5

Sample Output

0 1 2
#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
	int T,N,a[150],i,j,k,b[150],count;
	scanf("%d",&T);
	while (T--)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		count=0;
		scanf("%d",&N);
		for (i=0;i<N;i++)
		{
			scanf("%d",a+i);
			b[i]=a[i];
			for (j=0;j<i;j++)
			{
				if (a[i]==b[j])
				{
					for (k=j;k<=i;k++)
					{
						a[k]=-1;	
						b[k]=-1;
					}
					count++;
					break;
				}
			}
		}
		printf("%d\n",count);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值