杭电OJ 1005 Number Sequence

                                   Number Sequence

                Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                   Total Submission(s): 215888    Accepted Submission(s): 54628

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

Author

CHEN, Shunbao

Source

ZJCPC2004


最初我开设了100,000,000个数组,发现系统会崩溃。

后改用动态数组vector,结果Memory Limit Exceeded

#include<iostream>
#include<vector>
using namespace std;
int getValue(int a,int b,int n);
int main()
{
	int A,B,n;
	int result;
	while(cin>>A>>B>>n)
	{
		if(A==0&&B==0&&n==0)
		{
			break;
		}
		result=getValue(A,B,n);
		cout<<result<<endl;
	}
	return 0;
}
int getValue(int a,int b,int n)
{
	vector<int> ret;
	ret.clear();
	int i,temp;
	ret.push_back(1);
	ret.push_back(1);
	for(i=2;i<n;i++)
	{
		temp=(a*ret[i-1])+(b*ret[i-2]);
		temp=temp%7;
		ret.push_back(temp);
	} 
	return ret[n-1];
} 

AC算法:

f(n)最后结果要 mod 7,且f(n)的结果取决于f(n-1)与f(n-2),f(n-1)的取值范围为[0,6],f(n-2)的取值范围为[0,6],由于A,B是固定的,A*f(n-1)+B*f(n-2)的结果有7*7=49种,故f(n)的结果在这49种中无限循环。

#include<iostream>
using namespace std;
int getValue(int a,int b,int n);
int main()
{
	int A,B,n;
	int result;
	while(cin>>A>>B>>n)
	{
		if(A==0&&B==0&&n==0)
		{
			break;
		}
		result=getValue(A,B,n);
		cout<<result<<endl;
	}
	return 0;
}
int getValue(int a,int b,int n)
{
	int ret[50];
	int i,temp;
	ret[1]=1;
	ret[2]=1;
	for(i=3;i<50;i++)
	{
		ret[i]=(a*ret[i-1])+(b*ret[i-2]);
		ret[i]=ret[i]%7;
	} 
	return ret[n%49];
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值