杭电OJ 1005 Number Sequence

Number Sequence

页面数据来自(this page from): http://acm.hdu.edu.cn/showproblem.php?pid=1005

  • Time Limit: 2000/1000 MS (Java/Others)
  • Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A number sequence is defined as follows: f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

Author

CHEN, Shunbao      Source      ZJCPC2004

Statistic | Submit | Discuss | Note

Source Code

#include <iostream>
using namespace std; 
//原理: 每17个数形成一个周期 , 把下面的注释删掉,你打印出来就可以看到这个周期了
int main(){
	int A,B,n;
	while(cin >> A >> B >> n){
		if(A==0&&B==0&&n==0)return 0;
		int f[18];
	 	f[0] = 0;
		f[1]=f[2]=1;
		for(int i=3;i<17;i++){
			f[i] =  (A * f[i - 1] + B * f[i - 2]) % 7;
			//cout << "f["<< i <<"] : " << f[i]<<endl;
		}
		cout << f[n%17] << endl;
	}
	return 0;
}

时间复杂度 O(14)

周期:

0 1 1 2 3 4 1 6 0 6 6 5 4 2 6 1
这 16 个数就是一个周期

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值