阳仔博客

阳仔

ERROR ITMS-90206:"Invalid Bundle. The bundle at 'XXX.appex' contains disallowed file 'Frameworks'."

当我们上传我们的包到AppStore的时,有时候会报出错误:ERROR ITMS-90206:"Invalid Bundle. The bundle at 'XXX.appex' contains disallowed file 'Frameworks'."
发生错误的原因:我们使用了ios的extension扩展插件,比如today-widget,或者是AppWatch等。
解决办法:google上有大量的解决办法。但不一定能解决你的问题,下面给出解决办法:

首先进入项目Build Setting

  • For main project: Embedded Content Contains Swift Code to Yes

  • Custom Framework: Embedded Content Contains Swift Code to No

  • Custom Framework: Runpath Search Path = @executable_path/../../Frameworks

    尝试是否OK,一般情况下会OK的,如果还不行的话,继续下面的操作

    进入到扩展插件下->Build Phases 点击添加按钮,选择New Run Script Phase,然后将加入下面代码:

    cd "${CONFIGURATION_BUILD_DIR}/${UNLOCALIZED_RESOURCES_FOLDER_PATH}/"
    if [[ -d "Frameworks" ]]; then 
       rm -fr Frameworks
    fi

    好了,问题已经解决。Good Luck


阅读更多
版权声明:阳仔原创,转载请注明出处。 https://blog.csdn.net/honey199396/article/details/52352448
个人分类: iOS
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

ERROR ITMS-90206:"Invalid Bundle. The bundle at 'XXX.appex' contains disallowed file 'Frameworks'."

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭