百练162:Post Office

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 
输入
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.
输出
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.
样例输入
10 5
1 2 3 6 7 9 11 22 44 50
样例输出
9

分析:题目大意是说要在一维坐标轴上的V个村庄建立P个邮局,使村庄到最近邮局的总距离最小,区间动态规划中经典的邮局问题,用dp[i][j]表示前i个村庄建j个邮局,首先求出只建一个邮局的情况,然后再动态计算P(P>=2)个邮局时的最小距离

代码:

#include<cstdio>
#define min(a,b) ((a)<(b)?(a):(b))
int v,p,a[305],dp[305][305],dis[305][305];
int main(){
	scanf("%d%d",&v,&p);
	for(int i=1;i<=v;++i) scanf("%d",&a[i]);
	for(int i=1;i<=v;i++){
		for(int j=i+1;j<=v;j++)
			dis[i][j]=dis[i][j-1]+a[j]-a[(i+j)>>1];
	}
	for(int i=1;i<=v;++i){
		dp[i][1] = dis[1][i];
	}
	for(int r=2;r<=p;++r){
		for(int i=r+1;i<=v;++i){
			dp[i][r]=0x3f3f3f3f;
			for(int j=r-1;j<i;++j)
				dp[i][r]=min(dp[i][r],dp[j][r-1]+dis[j+1][i]);
		}
	}
	printf("%d\n",dp[v][p]);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值