1002. A+B for Polynomials (25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
#include<cstdio>
#include<queue>
using namespace std;
struct Node{
int ex;
float co;
Node(int e, float c):ex(e),co(c){}
};
bool isZero(float co){
if(co < 0) co = -co;
if(co < 1e-5) return true;
return false;
}
queue<Node> poly1;
queue<Node> poly2;
int main(){
int n,ex;
float co;
scanf("%d",&n);
while(n--){
scanf("%d%f",&ex,&co);
poly1.push(Node(ex,co));
}
scanf("%d",&n);
while(n--){
scanf("%d%f",&ex,&co);
poly2.push(Node(ex,co));
}
queue<Node> sum;
while(!poly1.empty() && !poly2.empty()){
Node p1 = poly1.front(), p2 = poly2.front();
if(p1.ex < p2.ex){
if(!isZero(p2.co)) sum.push(p2);
poly2.pop();
}else if(p1.ex == p2.ex){
float co = p1.co + p2.co;
if(!isZero(co)) sum.push(Node(p1.ex, co));
poly1.pop(); poly2.pop();
}else{
if(!isZero(co)) sum.push(p1);
poly1.pop();
}
}
while(!poly1.empty()){
sum.push(poly1.front());
poly1.pop();
}
while(!poly2.empty()){
sum.push(poly2.front());
poly2.pop();
}
int len = sum.size();
printf("%d",len);
while(!sum.empty()){
Node e = sum.front();
printf(" %d %.1f",e.ex,e.co);
sum.pop();
}
printf("\n");
return 0;
}