九度OJ1442:A sequence of numbers 解题报告

题目描述:

Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.

输入:

The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence. You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

输出:

Output one line for each test case, that is, the K-th number module (%) 200907.

样例输入:

2
1 2 3 5
1 2 4 5
  • 1
  • 2
  • 3
  • 4

样例输出:

5
16










判断如果k是奇数,则ans乘上q,此时等比就进行降幂。否则就是直接降幂。因为求等比和求等差都用到k-1或者是q^n-1所以直接对k进行减减。解题思路:题目两个要求:1是判断是等比还是等差2求第K个数值大小。难点在于等比的求值,我们采用二分求幂的办法。

#include<stdio.h>
int main(){
	int n;
	int ans,d,k,q;//d代表等差,q代表等比
	int a,b,c;
	while(~scanf("%d",&n)){
        while(n--){
            scanf("%d%d%d%d",&a,&b,&c,&k);
            k--;
            if(2*b==a+c) ans=a+k*(b-a);//若是等差数列,则进行等差数列的计算
            else{
                ans = a;//ans=1
                int q=b/a;//q=2/1=2
                while(k){    	//4 			2			1
                    if(k%2) 	//
                       ans *=q; //			    			ans=1*16=16
                    k /=2;     //2				k=1
                    q *=q;	   //q=4			q=16
                }
            }
            printf("%d\n",ans);
        }
	}
	return 0;
}
/*
2
1 2 3 5
1 2 4 5
5
16*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值