A sequence of numbers (入门题-数学)

                                                A sequence of numbers

                                                                                   Time Limit: 1 Seconds    Memory Limit: 32 Mbyte

题目描述:

      Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.

输入描述:

The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

输出描述:

Output one line for each test case, that is, the K-th number module (%) 200907.

输入样例:

2

1 3 5 8

2 4 8 7

输出样例:

15

128

分析:

开始我是拒绝的,以我的方法做了几下发现各种超,看了看其他人的才知道这是快速求幂

(http://blog.csdn.net/lsldd/article/details/5506933)快速求幂的解释

代码:

#include<stdio.h>
#define N 200907

__int64 fun(__int64 m,__int64 n)
{
    __int64 b=1;
    while(n)
    {
        if(n&1)
        b=(b*m)%N;
        n/=2;
        m=(m*m)%N;
    }
    return b;
}

int main()
{
    __int64 t;
    __int64 a,b,c,k;
    while(~scanf("%I64d",&t))
    {
        while(t--)
        {
            scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k);

            __int64 d;
            __int64 sum;
            if(b-a==c-b)
            {
                d=b-a;
                sum=(d*k-d+a)%N;
            }

            else if(b/a==c/b)
            {
                d=b/a;
                sum=(a*fun(d,k-1))%N;
            }
             printf("%I64d\n",sum);

        }
    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值