PAT 1130 Infix Expression

个人学习记录,代码难免不尽人意。

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child
where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG
infix2.JPG

Figure 1 Figure 2
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))
#include<cstdio>
#include<iostream>
#include<set>
#include<algorithm>
#include<string>
using namespace std;
const int maxn=25;
struct node{
	string data;
	string op;
	int lchild;
	int  rchild;
	bool flag;
}Node[maxn]; 
bool hashtable[maxn];
void print(int root){//flag为true代表左节点 
    if(root==-1) return;
    if(!(Node[root].lchild==-1&&Node[root].rchild==-1)){
     cout << "(";
	}

    print(Node[root].lchild);
    if(Node[root].flag)
    cout << Node[root].data;
    else
    cout << Node[root].op;
    print(Node[root].rchild);
    if(!(Node[root].lchild==-1&&Node[root].rchild==-1)){
     cout << ")";
	}
   
   
}
int main(){
   int n;
   scanf("%d",&n);
   fill(hashtable+1,hashtable+1+n,false);
   for(int i=1;i<=n;i++){
   	      string a;
   	      int left,right;
   	      cin >> a;
   	      scanf("%d %d",&left,&right);
   	      if(left!=-1)
   	      hashtable[left]=true;
   	      if(right!=-1)
   	      hashtable[right]=true;
   	      if(a[0]=='+'||a[0]=='-'||a[0]=='*'||a[0]=='\\'||a[0]=='%'){
   	      	     Node[i].op=a;
   	      	     Node[i].flag=false;
   	      	     Node[i].lchild=left;
   	      	     Node[i].rchild=right;
			 }
		  else{
		  	     Node[i].data=a;
   	      	     Node[i].flag=true;
   	      	     Node[i].lchild=left;
   	      	     Node[i].rchild=right;
		  }
   }
   int root;
   for(int i=1;i<=n;i++){
   	if(!hashtable[i]){
   		root=i;
   		break;
	   }
    }
 
    print(Node[root].lchild);
    if(Node[root].flag)
    cout << Node[root].data;
    else
    cout << Node[root].op;
    print(Node[root].rchild);
    printf("\n");
}

这道题是中序遍历的变式应用,我的做法可能有些复杂了,有些人好像并没有考虑输入的符号,我判断了符号再存储起来,事实可能没有必要这样做。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值