7-15 单继承中的构造函数与析构函数 (10 分)

19 篇文章 1 订阅

7-15 单继承中的构造函数与析构函数 (10 分

编写代码实现一个表示点的父类Dot和一个表示圆的子类Cir,求圆的面积。

Dot类有两个private数据成员 float x,y;

Cir类新增一个private的数据成员半径float r 和一个public的求面积的函数getArea( );

主函数已经给出,请编写Dot和Cir类。

#include <iostream>
#include<iomanip>
using namespace std;
const double PI=3.14;
//请编写你的代码
int main(){
    float x,y,r;
    cin>>x>>y>>r;
    Cir c(x,y,r);
    cout<<fixed<<setprecision(2)<<c.getArea()<<endl;
    return 0;
}

输入格式:

输入圆心和半径,x y r中间用空格分隔。

输出格式:

输出圆的面积,小数点后保留2位有效数字,注意:const double PI=3.14,面积=PI*r*r

输入样例:

在这里给出一组输入。例如圆的中心点为原点(0,0),半径为3:

0 0 4

输出样例:

在这里给出相应的输出。例如:

Dot constructor called
Cir constructor called
50.24
Cir destructor called
Dot destructor called

代码如下:

#include <iostream>
#include<iomanip>
using namespace std;
const double PI=3.14;

class Dot{
	private:
		float x,y;
	public:
		Dot(int a,int b):x(a),y(b){
			printf("Dot constructor called\n") ;
		}
		Dot(){
			printf("Dot constructor called\n") ;
		}
        virtual ~Dot(){
        	printf("Dot destructor called\n");
		}
};
class Cir:public Dot{
	private :
		float r;
	public :
	Cir(){
		printf("Cir constructor called\n") ;
	} 
	Cir(int a,int b,int c):Dot(a,b),r(c){
		printf("Cir constructor called\n") ;
	}
	 ~Cir(){
        	printf("Cir destructor called\n");
		}
	float getArea(){
		return r*r*PI;
	}
};
int main(){
    float x,y,r;
    cin>>x>>y>>r;
    Cir c(x,y,r);
    cout<<fixed<<setprecision(2)<<c.getArea()<<endl;
    return 0;
}

 原来不显式地写delete也会调用析构函数。

  • 4
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值