PAT 1136 A Delayed Palindrome

个人学习记录,代码难免不尽人意

在这里插入图片描述

A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

#include<cstdio>
#include<string>
#include<iostream> 
#include<algorithm>
#include<vector>
#include<set>
#include<queue>
#include<cmath>
using namespace std;
const int maxn=35;
struct bign{
	int num[1010];
	int len=0; 
};
bign add(bign a,bign b){
	bign c;
	int carry=0;
	int count=0;
	for(int i=0;i<a.len;i++){
		int temp=a.num[i]+b.num[i]+carry;
		int remain=temp%10;
		carry=temp/10;
		c.num[count++]=remain;
	}
	if(carry!=0) c.num[count++]=carry;
	c.len=count;
	return c;
}
bign Reverse(bign a){
	bign b;
	int count=0;
	for(int i=a.len-1;i>=0;i--){
		b.num[count++]=a.num[i];
	}
	b.len=count;
	return b;
}
void print(bign a){
	for(int i=a.len-1;i>=0;i--)
	printf("%d",a.num[i]); 
}
bool judge(bign a){
	int i=0,j=a.len-1;
	
	while(i<=j){
		if(a.num[i]!=a.num[j]){
			return false;
		}
		i++;
		j--;
	}
	return true;
}
int main(){
   string s;
   cin >> s;
   bign big;
   big.len=s.size();
   int count=0;
   for(int i=s.size()-1;i>=0;i--){
   	  big.num[count++]=s[i]-'0';
   }
   if(judge(big)){
   	 	print(big);
   	 	printf(" is a palindromic number.\n");
   	        return 0;
		}
   int i;
   for(i=0;i<10;i++){
   	 bign b=Reverse(big);
   	 print(big);
   	 printf(" + ");
   	 print(b);
   	 printf(" = ");
		big =add(big,b);
	 print(big);
	 printf("\n");
   	 if(judge(big)){
   	 	print(big);
   	 	printf(" is a palindromic number.\n");
   	         break;
		}
   }
 
   if(i==10) printf("Not found in 10 iterations.\n");
}

这道题涉及到的是大整数加法和转置。有两个坑点:如果一开始就是回文数的话需要直接输出is a palindromic number,而不是加的过程,然后就是如果最后一个测试点通不过,是出现了给的数的位数恰好等于1000的情况,这样相加的话就会超出1000位数,所以一开始设置的数组大小一定要大于1000

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值