PAT 1167 Cartesian Tree

个人学习记录,代码难免不尽人意。

A Cartesian tree is a binary tree constructed from a sequence of distinct numbers. The tree is heap-ordered, and an inorder traversal returns the original sequence. For example, given the sequence { 8, 15, 3, 4, 1, 5, 12, 10, 18, 6 }, the min-heap Cartesian tree is shown by the figure.
在这里插入图片描述
Your job is to output the level-order traversal sequence of the min-heap Cartesian tree.

Input Specification:
Each input file contains one test case. Each case starts from giving a positive integer N (≤30), and then N distinct numbers in the next line, separated by a space. All the numbers are in the range of int.

Output Specification:
For each test case, print in a line the level-order traversal sequence of the min-heap Cartesian tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the beginning or the end of the line.

Sample Input:
10
8 15 3 4 1 5 12 10 18 6
Sample Output:
1 3 5 8 4 6 15 10 12 18

#include<cstdio> 
#include<iostream>
#include<algorithm>
#include<cmath>
#include<queue>
#include<string> 
#include<vector>
using namespace std;
const int maxn=40;
const int INF=1000000000;
struct node{
	int data;
	node* lchild;
	node* rchild;
}; 
node* newnode(int data){
	node* root=new node;
	root->data=data;
	root->lchild=NULL;
	root->rchild=NULL;
	return root;
}
int in[maxn];
node* create(int inl,int inr){
	if(inl>inr) return NULL;
	int min=INF;
	int index;
	for(int i=inl;i<=inr;i++){
		if(in[i]<min){
			min=in[i];
			index=i;
		}
	}
	node* root=newnode(min);
	root->lchild=create(inl,index-1);
	root->rchild=create(index+1,inr);
	return root;
}
void bfs(node* root,int n){
	queue<node*> q;
	q.push(root);
	int cnt=0;
	while(!q.empty()){
		node* now=q.front();
		q.pop();
		printf("%d",now->data);
		cnt++;
		if(cnt!=n) printf(" ");
		else printf("\n");
		if(now->lchild!=NULL) q.push(now->lchild);
		if(now->rchild!=NULL) q.push(now->rchild);
	}
}
int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
    	scanf("%d",&in[i]);
	}
	node* root=create(0,n-1);
	bfs(root,n);
}

这道题简单的出乎我的意料了,就是最简单的建树+bfs遍历,出在最后一题有些反套路了,这也提醒我们一道题不要耗太多时间,后面说不定有送分题。因为前面三道都记录了,这道题我也记录一下吧。O(∩_∩)O哈哈~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值