hdu-oj 1013 Digital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48266    Accepted Submission(s): 15000


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
  题目大意:大数分解各位相加,如果结果大于10,则将所得和继续分解相加,直至小于10;输出结果。

问题分析:因为不会有正数各位之和为0,所以只会有1-9这9个根。

假设,数d的根为d%9!!!!!!!!(不取0,整除时取9)

首先,1-9这9个数成立
假定,d的根为d%9,则d+1的根为d的根+1,即d%9+1=(d+1)%9.
得证。

第二步详细一点的说明:
d表示为a1a2a3a4...aN,d+1表示为a1a2a3a4...(aN+1)
d+1与a1a2a3a4...aN+1同根,即d%9+1。

考虑大数的情况,需要做一次处理,程序简单如下:

 

#include <stdio.h>
char s[10000];
int main() {
    char *p; 
    int d;

    while (scanf("%s", s) > 0)  {
        p = s;
        d = 0;
        while (*p) {       //对于大数,直接求一次各位的和。
            d += *p - '0';
            ++p;
        }
        if (d == 0) break; //输入0,退出。

        d %= 9;
        if (d == 0) d = 9; //整除取9.
        printf("%d\n", d);
    }
    return 0;
}


附另一简单易懂代码:

<span style="font-size:12px;color:#000000;">#include <stdio.h>
#include <string.h>
int fenjie(int num)
{
    int sum=0;
    while(num>=10)
    { sum+=num%10;
      num/=10;
    }
    sum+=num;
      return sum;
}
int main()
{
    
	char sum[1010];
	while(gets(sum)&&sum[0]!='0')
	{
		int i,x=0;
		for(i=0;i<strlen(sum);i++)
		{
			x += sum[i] - '0';	
		}
			while(x>=10)
		{
			x = fenjie(x);
		}
		printf("%d\n",x);
	}	
		
    return 0;
}
</span>



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值