hdu-oj 1266 Reverse Number

Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5059    Accepted Submission(s): 2357


Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!
Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 Output
For each test case, you should output its reverse number, one case per line.
 Sample Input
  
  
3 12 -12 1200
 Sample Output
  
  
21 -21 2100
 
题目大意:将数据逆序输出;‘-’始终在第一位,末尾的‘0’位置也不变;
解题思路:利用字符串方便逆序输出,利用循环找出末尾是否有‘0’和‘0’的个数。并确定第一位是否为‘-’。
附代码:
#include <stdio.h>
#include <string.h>
char s[10000000];
int main()
{  int t,i,j,k,m;
    scanf("%d",&t);
    while(t--){
      getchar(); 
      memset(s,'\0',sizeof(s));
      scanf("%s",s);
      m=strlen(s);
      for(i=m-1;i>0;i--)
        { if(s[i]!='0')
            break;}
      if(s[0]=='-') printf("%c",s[0]);
       for(j=i;j>0;j--)
          printf("%c",s[j]);
        if(s[0]!='-') printf("%c",s[0]);
       for(k=m-1;k>i;k--)
          printf("%c",'0');
         printf("\n"); i=j=k=0;     
    }
    return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值