hdu 1222 Wolf and Rabbit

Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 


 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 


 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 


 

Sample Input
  
  
2 1 2 2 2
 


 

Sample Output
  
  
NO YES

 

 

方法一:

                 如果n,m存在大于1 的公约数,则会有漏洞让兔子去容身

#include<stdio.h>
int gct(int a,int b)
   {
   	  if(a==0)
   	     return b;
   	  else
   	     return gct(b%a,a);
   }
  int main()
    {
    	 int T;
    	 int m,n;
    	 scanf("%d",&T);
    	 while(T--)
	      {
	      	scanf("%d%d",&n,&m);
			   if(gct(n,m)==1)
			      printf("NO\n");
			   else
			      printf("YES\n");
	      }
       return 0;
    }


 方法二:

            如果n,m存在倍数关系,则会有漏洞让兔子容身,如果n,m都是偶数,则兔子也可以容身,或者说,n,m都为1,也可以;其他情况则兔子会被耐心的吃掉。

  

#include<stdio.h>
#include<string.h>
  int main()
    {
         int T;
         __int64 m,n;
         scanf("%d",&T);
         while(T--)
          {
              scanf("%I64d%I64d",&n,&m);
                if(m==1||n==1)
                    printf("NO\n");
                else
                   {
                   	  if(n%2&&m%2)
                   	     printf("YES\n");
                   	  else
                   	    {
                   	    	if((n%m==0)||(m%n==0))
                   	    	   printf("YES\n");
                   	    	else
                   	    	   printf("NO\n");
                   	    }
                   }
          }
       return 0;
    }


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值