hdu 1905 Pseudoprime numbers 快速幂取余

Pseudoprime numbers

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2058    Accepted Submission(s): 824


Problem Description
Fermat's theorem states that for any prime number p and for any integer a > 1, a^p == a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.) 
Given 2 < p ≤ 1,000,000,000 and 1 < a < p, determine whether or not p is a base-a pseudoprime. 
 

Input
Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.
 

Output
For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no". 
 

Sample Input
  
  
3 2 10 3 341 2 341 3 1105 2 1105 3 0 0
 

Sample Output
  
  
no no yes no yes yes
 

Author
Gordon V. Cormack
 


#include<stdio.h>
#include<string.h>
//快速幂模板
// m^n%k 
__int64 quick(__int64 m,__int64 n,__int64 k)
{
    __int64 b=1;
    while(n>0)
    {
        if(n & 1) //n是奇数
           b = (b*m)%k;
        n=n>>1;//相当于n/2;
        m=(m*m)%k; 
    }
  return b;
}
__int64 judge(__int64 n)
{
    if(n<=1)
      return 0;
    for(int i=3;i*i<=n;i++)
    {
        if(n%i==0)
          return 0; 
    }
    return 1;
}
int main()
{
    __int64 a,p;
    while(scanf("%I64d%I64d",&p,&a)&&!(a==0&&p==0))
    {
        if(judge(p))
         {
             printf("no\n");
             continue;
         }
        else if(quick(a,p,p)==a)
         {
              printf("yes\n");
              continue;
         }
        else
        {
            printf("no\n");
            continue;
        }
    }
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值