hdu 5074 怎么才算简单dp

3 篇文章 0 订阅

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 857    Accepted Submission(s): 605


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n (-1 ≤ a i ≤ m, a i ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
  
  
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
  
  
270 625
 

Source
 

      遇见了dp,可惜又可悲,简单的dp,由于DP联系的较少,还是不知道如何下手,几经辗转,和队友讨论了一下,确定了dp方程
        if(note[i]!=-1)
   {
  if(note[i-1]!=-1)  //都不能替换
    dp[i][note[i]] = dp[i-1][note[i-1]]+score[note[i-1]][note[i]];
  else   // 可换一个 
   dp[i][note[i]] =max(dp[i][note[i]] , dp[i-1][j]+score[j][note[i]]);
   }
  else   
  {
    if(note[i-1]!=-1)   //换一个 

       dp[i][j]=max(dp[i][j] ,dp[i-1][note[i-1]]+score[note[i-1]][j]);
 
    else    //换两个 
 dp[i][j]=max(dp[i][j] ,dp[i-1][k] +score[k][j]);

题意为有m种音符,编号1到m,我们要用这m种音符来创造一首带有n个音符的曲子(当然,一种音符可以用多次),假设有两个连续的音符 i ,j ,那么定义score(i,j)为这两个音符的得分,题目中预先给出所有的score(i,j)   1<=i,j<=m, 那么我们创造出的n个音符的曲子的得分为  score( note[i] , note[i+1] ) + score (note[i+1] ,note[i+2) +......score(note[n-1],note[n]) , i从1开始。 note [i] 代表n个音符的曲子中第i个音符是第几种音符, 1<=note[i]<=m, 比如 note[i]=3,就表示n个音符中第i个位置用的是第3种音符(一共有m种),预先给出 这n个音符,note[1] 到note[n] ,其中note[ i] 或者等于-1 ,或者 大于等于1小于等于m,对于后者,该位置的音符不能改变,对于前者,该位置可以换成任意的音符j(1<=j<=m), 问 这n个音符所获得的最大得分是多少。


关键点就是  note =-1时候可以1-m之间随意调换, 其他则不可以。


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[102][52];
int score[52][52];
int note[102];
int n,m;
int solve()
{
	for(int i=2;i<=n;i++)
	{
	    if(note[i]!=-1)
	    {
		   if(note[i-1]!=-1)  //都不能替换
		     dp[i][note[i]] = dp[i-1][note[i-1]]+score[note[i-1]][note[i]];
		   else   // 可换一个 
		   {
		 	   for(int j=1;j<=m;j++)
		 	   {
		 	  	  dp[i][note[i]] =max(dp[i][note[i]] , dp[i-1][j]+score[j][note[i]]);
		 	   }
		  }
	   }
	   else   
	   {
	  	   if(note[i-1]!=-1)   //换一个 
	  	   {
	  	   	   for(int j=1;j<=m;j++)
	  	   	   {
	  	   	   	  dp[i][j]=max(dp[i][j] ,dp[i-1][note[i-1]]+score[note[i-1]][j]);
	  	   	   }
	  	   }
	  	   else    //换两个 
	  	   {  
	  	   	  for(int j=1;j<=m;j++)
			  {
			      for(int k=1;k<=m;k++)
				  {
				  	  dp[i][j]=max(dp[i][j] ,dp[i-1][k] +score[k][j]);
				  } 
	  	      }
	  	
	        }
	  }  
   }
   	  int ans=-1;
	  if(note[n]!=-1)
	      ans=dp[n][note[n]];
	  else
	  {
	  	   for(int j=1;j<=m;j++)
	  	   {
	  	   	   if(ans<dp[n][j])
	  	   	      ans=dp[n][j];
	  	   }
	  }
return ans; 
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		memset(score,0,sizeof(score));
		for(int i=1;i<=m;i++)
		{
			for(int j=1;j<=m;j++)
			scanf("%d",&score[i][j]); 
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",¬e[i]);
		}
	 memset(dp,0,sizeof(dp));
	  int ans=solve();
	     printf("%d\n",ans);
	}

return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值