poj Seuence


Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

A seuence  qof N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题目大意:给出一组数,从中找出最小的序列,使他们的和干好>=S

解题思路:由于是找出连续的数列,所以从左边开始加,直到和超出S,超出之后依次剪掉左边的,前世保证和在大于等于S,同时在剪掉之前,向找到此时的数列区间,意思就是加到得最右边位置,减去最左边的位置。这样的过程会有多个,留下最小的。在减得和小于S之后,接着刚才的,继续往右加。知道最后结束。

#include<stdio.h>
#include<string.h>
const int MAX=100100;
int a[100010]; 
int main()
{
	int n,s;
	int T;
	int S;
	int min;
	int j,k,i;
	while(scanf("%d",&T)!=EOF)
	{
		
		while(T--)
		{ 
			scanf("%d%d",&n,&s);
			memset(a,0,sizeof(a));
			for(i=0;i<n;i++)
			{
				scanf("%d",&a[i]);
			}
			S=0;
			i=0;
			min=MAX;
			for(j=0;j<n;)
			{
				S+=a[j++];
				if(S<s&&j<n) continue;
				while(S>=s)
				{
					int temp;
					temp=j-i;
					min=min>temp?temp:min;
					S-=a[i];
					i++;
				}
			} 
			if(min==MAX)//没有找到
			    printf("0\n");
			else
				printf("%d\n",min) ;
		} 
	}
return  0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值