HDU 1894--String Compare【string】

23 篇文章 0 订阅

String Compare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3144    Accepted Submission(s): 749


Problem Description
Maybe there are 750,000 words in English and some words are prefix of other words, for example: the word "acm" can be treat as one prefix of "acmicpc". What's more, most of such pairs of words have relationship between them. Now give you a dictionary, your work is to tell me how many such pairs.


There may be other characters in the word, for example '_','-',and so on.
Pay attention that 'A' and 'a' are not the same character!
 

Input
In the first line of the input file there is an Integer T, which means the number of test cases. Followed by T test cases.
For each test case, in the first line there is an integer N(0<N<=50000), followed N lines, each contains a word whose length is less than 30 and no space appears in any word. There are no same words in two different lines.
 

Output
For each test case, tell me how many such pairs. If the number is larger than 11519, just divide it by 11519 and only output the remainder.
 

Sample Input
  
  
2 2 acmicpc acm 3 a abc ab
 

Sample Output
  
  
1 3
 
string compare函数:http://www.tuicool.com/articles/auEzqy

#include <iostream>
#include <algorithm>
using namespace std;

string s[100010];
int main (){
    int t,i,j,n,ans;
    cin>>t;
    while(t--){
        ans=0;
        cin>>n;
        for(i=0;i<n;++i)
            cin>>s[i];
        sort(s,s+n);
        for(i=0;i<n-1;++i){
            for(j=i+1;j<n;++j){
                if(s[i].size()>=s[j].size()) break;
                if(s[i].compare(0,s[i].size(),s[j],0,s[i].size())==0)
                    ans++;
                else break;
            }
        }
        if(ans>11519) ans%=11519;
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值