POJ 3450--Corporate Identity【KMP && 枚举】

12 篇文章 0 订阅

Corporate Identity
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5696 Accepted: 2075

Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST
思路:枚举一个串的所有子串,判断该子串有没有在其它串中出现。若在其它串中全部出现 则更新子串,否则枚举下一个子串。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char str[4010][210];
int next[210];

void getnext(char *s1){
    int j = 0, k = -1;
    int len = strlen(s1);
    next[0] = -1;
    while(j < len){
        if(k == -1 || s1[j] == s1[k]){
            ++j;
            ++k;
            next[j] = k;
        }
        else k = next[k];
    }
    return ;
}

bool kmp(char *s1, char *s2){
    int len1 = strlen(s2);
    int len2 = strlen(s1);
    getnext(s1);
    int i = 0, j = 0;
    while(i < len1){
        if(j == -1 || s1[j] == s2[i]){
            ++i;
            ++j;
        }
        else j=next[j];
        if(j == len2)
            return true;
    }
    return false;
}

int main(){
    int n;
    while(scanf("%d", &n), n){
        for(int i = 0 ; i < n; ++i)
            scanf("%s", str[i]);
        char temp[220];
        char sum[220] = "";
        int len = strlen(str[0]);
        for(int i = 0; i < len; ++i){
            int ans  = 0;
            for(int j = i; j < len; ++j){
                temp[ans++] = str[0][j];
                temp[ans] = '\0';
                int flag = 1;
                for(int k = 0 ; k < n; ++k){
                    if(!kmp(temp, str[k])){
                        flag = 0;
                        break;
                    }
                }
                if(flag){
                    if(strlen(temp) > strlen(sum))
                        memcpy(sum, temp, sizeof(temp));
                    else if(strlen(temp) == strlen(sum) && strcmp(temp, sum) < 0)
                        memcpy(sum, temp, sizeof(temp));
                }
            }
        }
        if(strlen(sum) == 0)
            printf("IDENTITY LOST\n");
        else
            printf("%s\n", sum);
    }
    return 0;
}


  • 6
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值