HDU 3836--Equivalent Sets【求有向图最少增加多少边使图强连通 && Scc缩点新建图】

Equivalent Sets

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 3502    Accepted Submission(s): 1211


Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
 

Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
 

Output
For each case, output a single integer: the minimum steps needed.
 

Sample Input
  
  
4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
Hint
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.
 
转化模型:求至少需要添加多少条边,才能使这个图变成强连通图。和HDU2726基本一模一样, 解析不就不再写了,想看解析的可以点这里 HDU 2726

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
#define maxn 20000 + 1000
#define maxm 50000 + 5000
using namespace std;
int n, m;
int low[maxn], dfn[maxn];
int dfs_clock;
int Stack[maxn];
bool Instack[maxn];
int top;
int Belong[maxn];
int scc_clock;
int out[maxn], in[maxn];
vector<int>edge[maxm];

void getmap(){
    for(int i = 1; i <= n; ++i)
        edge[i].clear();
    while(m--){
        int a, b;
        scanf("%d%d", &a, &b);
        edge[a].push_back(b);
    }
}

void tarjan(int u, int per){
    int v;
    low[u] = dfn[u] = ++dfs_clock;
    Stack[top++] = u;
    Instack[u] = true;
    for(int i = 0; i < edge[u].size(); i++){
        v = edge[u][i];
        if(!dfn[v]){
            tarjan(v, u);
            low[u] = min(low[v], low[u]);
        }
        else if(Instack[v]){
            low[u] = min(low[u], dfn[v]);
        }
    }
    if(dfn[u] == low[u]){
        scc_clock++;
        do{
            v = Stack[--top];
            Instack[v] = false;
            Belong[v] = scc_clock;
        }while(u != v);
    }
}

void find(){
    memset(low, 0, sizeof(low));
    memset(dfn, 0, sizeof(dfn));
    memset(Instack, false, sizeof(Instack));
    memset(Belong, 0, sizeof(Belong));
    dfs_clock = scc_clock = top = 0;
    for(int i = 1; i <= n; ++i){
        if(!dfn[i])
            tarjan(i, i);
    }
}

void suodian(){
    for(int i = 1; i <= scc_clock; ++i){
        in[i] = 0;
        out[i] = 0;
    }
    for(int i = 1; i <= n; ++i){
        for(int j = 0; j < edge[i].size(); ++j){
            int u = Belong[i];
            int v = Belong[edge[i][j]];
            if(u != v){
                out[u]++, in[v]++;
            }
        }
    }
}

void solve(){
    if(scc_clock == 1){
        printf("0\n");
        return ;
    }
    int numin = 0, numout = 0;
    for(int i = 1; i <= scc_clock; ++i){
        if(in[i] == 0) numin++;
        if(out[i] == 0) numout++;
    }
    printf("%d\n", max(numin, numout));
}

int main (){
	while(scanf("%d%d", &n, &m) != EOF){
        getmap();
        find();
        suodian();
        solve();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值