HDU 2579--Dating with girls(2)【BFS && 三维判重】

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2656    Accepted Submission(s): 741


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
  
  
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
  
  
7
 
题意:从Y 走到 G,每走一步要一秒, . 是可以走的路,#是墙,和普通的BFS不一样,这里的石头# 在时间%k == 0的时候是可以消失的,即使可以走的。如果不等于0 就会又出现。


解析:

从起点到终点,bfs,不同的是对于图中的点,可能走多次,分别是在不同的时刻。
vis[ i ][ j ][ t%k ]=1:表示坐标( i,j )在 t %k 时刻走过,接下来再出现 t%k 就不用再走一次了。

#include <iostream>
#include <algorithm>
#include <queue>
#include <algorithm>
#include <cstring>
#define maxn 110
using namespace std;
int n, m, k;
int sx, sy;
int vis[maxn][maxn][11];
char map[maxn][maxn];
int dir[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};

struct node {
    int x, y, step;
};

void bfs(){
    memset(vis, 0, sizeof(vis));
    queue<node>q;
    node st, ed;
    st.x = sx; st.y = sy; st.step = 0;
    q.push(st);
    while(!q.empty()){
        st = q.front();
        q.pop();
        if(map[st.x][st.y] == 'G'){
            printf("%d\n", st.step);
            return ;
        }
        for(int i = 0; i < 4; ++i){
            ed = st;
            ed.x += dir[i][0];
            ed.y += dir[i][1];
            ed.step++;
            int d = ed.step % k;
            if(ed.x < 0 || ed.x >= n || ed.y < 0 || ed.y >= m || (map[ed.x][ed.y] == '#' && d)) continue;
            if(vis[ed.x][ed.y][d]) continue;
            q.push(ed);
            vis[ed.x][ed.y][d] = 1;
        }
    }
    printf("Please give me another chance!\n");
}

int main (){
    int T;
    scanf("%d", &T);
    while(T--){
        scanf("%d%d%d", &n, &m, &k);
        for(int i = 0; i < n ;++i){
            scanf("%s", map[i]);
            for(int j = 0; j < m; ++j){
                if(map[i][j] == 'Y')
                    sx = i, sy = j;
            }
        }
        bfs();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值