杭电2579-Dating with girls(2) (非常清晰易懂的代码)

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1476    Accepted Submission(s): 419


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
  
  
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
  
  
7
/*
在时间能被k整除的时候障碍会消失
这样就需要在一般的二维迷宫判重数组上加上一维
这一维的意义是总时间模k的余数
mark[i][j][t]的意义是总时间模k余time时在x,y点
因为一个格子上不同的时间余数代表不同的状态
在这些状态下扩展出的节点可能不同
所以需要三维判重,而当时间余数相同的时候
就没有必要继续扩展了,因为接下去扩展出的节点
他们的状态我们一定扩展过了。
*/
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<iomanip>
const int MAX=101;
int direction[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//表示上下左右四个方向
char map[MAX][MAX];//迷宫地图
int mark[MAX][MAX][MAX];//在时间为t情况(x,y)点是否标记过
int r,c,k;//行,列,k值
int x,y,xx,yy,step;//(x,y)代表起点即男孩的位置,(xx,yy)是终点即女孩的位置
using namespace std;
typedef struct Node//定义结构体
{
    int x;
    int y;
    int time;
}node;
node s[MAX];
bool judge(node x)//判断
{
    if(x.x<0||x.x>=r||x.y<0||x.y>=c)//如果走出界
    return false;
    if(mark[x.x][x.y][x.time%k])//如果该点在已经标记过
    return false;
    if(map[x.x][x.y]=='#'&&x.time%k!=0)//如果走到石头前但是石头没有消失
    return false;
    return true;
}
int BFS()
{
    node temp,a;
    queue<node>que;//定义一个队列
    a.x=x;//赋初值
    a.y=y;
    a.time=0;
    que.push(a);
    mark[a.x][a.y][a.time]=1;//起点已经标记
    while(!que.empty())//开始深搜
    {
        a=que.front();
        que.pop();
        for(int i=0;i<4;i++)
        {
            temp.x=a.x+direction[i][0];
            temp.y=a.y+direction[i][1];
            temp.time=a.time+1;
            if(judge(temp))
            {
                if(temp.x==xx&&temp.y==yy)//如果搜到终点
                return temp.time;
                mark[temp.x][temp.y][temp.time%k]=1;
                que.push(temp);
            }
        }
    }
    return -1;//如果搜不到就返回-1
}
int main()
{
    int t,i,j,ans;
    cin>>t;
    while(t--)
    {
        cin>>r>>c>>k;
        for(i=0;i<r;i++)
        {
            for(j=0;j<c;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='Y')
                {
                    x=i;
                    y=j;
                }
                if(map[i][j]=='G')
                {
                    xx=i;
                    yy=j;
                }
            }
        }
        memset(mark,0,sizeof(mark));
        ans=BFS();
        if(ans!=-1)
        cout<<ans<<endl;
        else
        cout<<"Please give me another chance!"<<endl;
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值