HDUOJ_2680(Choose the best route )(dijkstra)

HDUOJ_(Choose the best route )2680(dijkstra)

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10606    Accepted Submission(s): 3418


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              /*说明输入的数据是有向的*/
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.  
Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
Sample Output
  
  
1 -1
Author
Source



—————————————————————————————————————————————————————————————————————

提示:该题大意是有 多个起点,终点只有一个。最后找出到达终点的最短时间,若不能到达终点则输出-1。
由于 起点有多个,而终点只有一个,若从起点开始查找,需要多次调用dijistra函数。这道题若这样解可能会超时。换个思路把终点当作起点,把原先的起点当作终点,逆序查找。这样就 变成一个起点多个终点的问题了,这样只需调用dijkstra函数一次。

注意该题输入的数据是有向的(有向图)如:map[a][b]!=map[b][a](在题中处理数据时不能把二者看作相同。如:若map[a][b]=c;不能把map[b][a]=c,因为该题为有向图,所以不能这样操作)。

My  solution:
/*2015.8.18*/
#include<stdio.h>
#include<string.h>
#include<algorithm> 
using namespace std;
#define  INF  0x3f3f3f3f 
int map[1010][1010],d[1010],mark[1010],n;
void  dijkstra(int s)
{
	int i,v;
	d[s]=0;
	while(1)
	{
		v=-1;
		for(i=1;i<=n;i++)
		if(!mark[i]&&(v==-1||d[v]>d[i]))
		v=i;
		if(v==-1)
		break;
		mark[v]=1;
		for(i=1;i<=n;i++)
		d[i]=min(d[i],d[v]+map[v][i]);	
	}	
}
int main()
{
	int i,j,m,ex,ey,a,b,c,t,min;
	while(scanf("%d%d%d",&n,&m,&ey)==3)
	{
		min=INF;
		memset(mark,0,sizeof(mark));
		memset(d,0x3f,sizeof(d));
		memset(map,0x3f,sizeof(map));
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[b][a]>c) /*该题为有向图,由于逆向操作(起点当作终点,原来的终点变成起点)*/
			{                                               /*所以把数据的方向也该成逆向*/ 
			//	map[a][b]=c;/*有向图且按逆序操作因此不能执行该条语句*/
				map[b][a]=c;
			}
		}
		dijkstra(ey); /*一个起点*/
		scanf("%d",&t);
		for(i=0;i<t;i++)/*多个终点*/
		{
			scanf("%d",&ex);
			if(min>d[ex])
			min=d[ex];/*存放花费最少的时间*/
		}
		if(min!=INF)
		printf("%d\n",min);	
		else
		printf("-1\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值