HDOJ-2057(A + B Again)

HDOJ-2057(A + B Again)

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

Sample Input
  
  
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output
  
  
0 2C 11 -2C -90
 
注:由于题目所说的16进制数长度小于15位,所以换算成2进制位的话小于64(16*4)位,需用长整形。

long  long  和_int64输出16进制数时,不能输出负数,若是负数必须转换一下。(看了别人的博客才知道的)

My  solution:

/*2016.3.3*/

#include<stdio.h>
int main()
{
	long long n,m,v;
	while(scanf("%llx%llx",&n,&m)==2)
	{
		v=n+m;
		if(v<0)
		{
			v=-v;
			printf("-%llX\n",v);	
		}
		else
		printf("%llX\n",v);	
	}  
     return 0;
 } 


  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值