POJ_1995(快速幂)(Raising Modulo Numbers)

POJ_1995(快速幂)(Raising Modulo Numbers)

Raising Modulo Numbers
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5498 Accepted: 3183

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

提示: 取模(取余),注意:此题不能直接先求Bi次方和再取余,因为从样例中的一组数据(Ai=2374859,Bi=3029382)便可以看出,得到的结果是一个很大的数,即使用long  long(_int64),仍然会溢出。(最后一组数据相对上一组,小很多,3的18132次方用long  long存,得到的结果是一个负数,说明溢出了。)。此题需要转换一下思路:

     

                 (78^5)%35

                 78*78^4(78^5)

              =[ (78%35)+(78/35)*35 ]*78^4

              =(78%35)*78^4+(78/35)*35*78^4(把原式分成两部分,前者是78%35的余数和78^4的乘积,后者是78/35的商和35及78^4的积.)

              =……                                                   (显然后者是35的整数倍可以不予考虑,只考虑前者即可,把前者继续对35进行取余,依此类推)


     情况一:    (n*m)%c

           (m*n)%c

         =( (m%c)*(n%c) )%c

         例:   (85*135)%35

                 =[ (2*35+15) *(35*3+30) ]%35

                 =[ (2*35)*(35*3)+15*(35*3)+30*(2*35)+15*30]%35  /*前3个式子都是35的整数倍,15=(85%35),30=(135%35)*/

         即:=[ (85%35)*(135%35) ]%35


    情况二:(n+m)%c

  例:      (85+135)% 35                (85=35*2+15  ,  135=35*3+30)

              =(35*(3+2)+30+15)%35

              =(30+15)%35

            (n+m)%c

           =(n%c+m%c)%c

My   solution:

/*2015.8.22*/

注意:在进行取余操作时,若用for循环一个余数一个余数求,会超时,需用快速幂的方法来求。

#include<stdio.h>/*如果题中的Ai和M都没有超出int型范围,则下面就不需用long long(_int64)型数据*/
int h[5000][2],m; /*下面代码主要是对(Ai%M),进行操作,所以二者若没有超出int型范围,代码就不需用long long*/
                   /*h数组存放Ai和Bi*/
int mi(int a,int b) /*取余+快速幂*/  
{
	int ans=1;
	while(b)
	{
	  if(b%2)
	  ans=(ans*a%m);
	  a=((a%m)*(a%m))%m;
	  b=b/2;
	}
    return ans%m;
}
int main()
{
	int i,j,n,t,mod,sum;
	scanf("%d",&n);
	while(n--)
	{
		sum=0;mod=0;
		scanf("%d%d",&m,&t);
		for(i=0;i<t;i++)
		{
			scanf("%d%d",&h[i][0],&h[i][1]);
			sum+=mi(h[i][0],h[i][1]);
		}
	    mod=sum%m;
	    printf("%d\n",mod);
	}
	return 0;
}

用long long 型数据:

#include<stdio.h>
long long  h[5000][2],m;
long long mi(long long a,long long b)
{
	long long ans=1;
	while(b)
	{
	 if(b%2)
	  ans=(ans*a%m);
	  a=((a%m)*(a%m))%m;
	  b=b/2;
	}
    return ans%m;
}
int main()
{
	long long i,j,n,t;
	long long sum,mod;
	scanf("%I64d",&n);
	while(n--)
	{
		sum=0;mod=0;
		scanf("%I64d%I64d",&m,&t);
		for(i=0;i<t;i++)
		{
			scanf("%I64d%I64d",&h[i][0],&h[i][1]);
			if(m!=0)
			sum+=mi(h[i][0],h[i][1]);/*当m=0时,不进行函数调用,数据不处理.但数据仍要输入,由于m先于测试数据输入,当判断m=0后,若*/
		} /*停止此次操作,由于输入的数据没有存放到相应变量中,在执行下一次操作时,这些数据会自动填充到其它变量中导致程序出错*/
	    if(m!=0)
	      mod=sum%m;
	      printf("%I64d\n",mod);/*该题当m=0时,输出任意值都能AC,或者没有输出也能AC*/
	}
	return 0;
}






以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值