HDOJ-2056(Rectangles)

16 篇文章 0 订阅

Rectangles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19475    Accepted Submission(s): 6316


Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
 

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
 

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
 

Sample Input
  
  
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
 

Sample Output
  
  
1.00 56.25
 
注: 刚开始感觉这道题不难,但却不好做,需要考虑分析的情况太多了。思考了好久才找到下面本人认为比较巧妙的方法。可是在提交代码却wrong answer想了好久才发现自己忽略了下图中的第四种情况。

My   solution:
#include<stdio.h> 
#include<algorithm>
using namespace std;
int main()
{
	int  i,j,k,n,m;
	double x[5],y[5],a[5],b[5],s;
	while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x[1],&y[1],&x[2],&y[2],&x[3],&y[3],&x[4],&y[4])==8)
	{
		s=0;
		for(i=1;i<=4;i++)
		{
			a[i]=x[i];
			b[i]=y[i];
		}//a[]、b[]数组记录原来数据 
		sort(x+1,x+5);
		sort(y+1,y+5);
		if(x[3]>a[2]&&x[3]>a[1]||x[3]>a[3]&&x[3]>a[4]||y[3]>b[1]&&y[3]>b[2]||y[3]>b[3]&&y[3]>b[4]) 
		;                                                               //判断两个矩形没有相交
		else
		s=(x[3]-x[2])*(y[3]-y[2]);
		printf("%.2lf\n",s);
	}
	
	return 0;
}


  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值