HDOJ2056_Rectangles

Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
 
Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
 
Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
 
Sample Input
  
  
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
 
Sample Output
  
  
1.00 56.25
题目大意:求两个相交矩形的面积,两个矩形的边都是平行x或y轴的,输入x1,y1,x2,y2,x3,y3,x4,y4,输出保留两位小数的面积值
下面代码兼解析:
import java.util.Scanner;

public class Main {
	private static Scanner scanner;

	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		while (scanner.hasNext()) {

			//为方便查看,数组中的第一个元素不使用,且称为点1,点2...
			double[] x = new double[5];
			double[] y = new double[5];
			double area = 0;
			//输入
			for (int i = 1; i < 5; i++) {
				x[i] = scanner.nextDouble();
				y[i] = scanner.nextDouble();
			}
			
			//交换,保证最下面的矩形是点1,点2的
			if (x[1] > x[2]) {
				swap(x, 1, 2);
			}
			if (y[1] > y[2]) {
				swap(y, 1, 2);
			}
			if (x[3] > x[4]) {
				swap(x, 3, 4);
			}
			if (y[3] > y[4]) {
				swap(y, 3, 4);
			}
			//这是相交的部分,重新定义两个变量来记录
			//相交部分的点1点3取最大值,点2点4取最小值
			double x1 = x[1] > x[3] ? x[1] : x[3];
			double x2 = x[2] < x[4] ? x[2] : x[4];
			double y1 = y[1] > y[3] ? y[1] : y[3];
			double y2 = y[2] < y[4] ? y[2] : y[4];

			//如果没相交就面积为0
			if (x2 < x1 || y2 < y1) {
				area = 0;
			} else {
				area = (x1 - x2) * (y1 - y2);
			}
			System.out.printf("%.2f", area);
			System.out.println();
		}
	}
	//交换两个数组元素的方法
	public static void swap(double[] a, int i, int j) {
		double t = a[i];
		a[i] = a[j];
		a[j] = t;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值