HDU-1027(Ignatius and the Princess II)(全排列dfs())

19 篇文章 0 订阅

HDU-1027(Ignatius and the Princess II)(全排列dfs())

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6410    Accepted Submission(s): 3793


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
  
  
6 4 11 8
 

Sample Output
  
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

 注:这题主要考查n个数的全排列,m表示取第几个排列(排列情况:从小到大变,取第m小的组合,也就是取第m个组合)
//由于n<1000,如果全部遍历,共有1000!种排列,考虑到dfs(),由于m<10000可能会超时。于是想到优化。t个数的全排列共有 t!种排列,由于m<10000,而经过计算      8!=40320,所以最多只用把后8位用全排列遍历,前面的数字直接打印输出即可。
//注:我旁边的同学直接调用函数库中的全排列函数,也AC了。

My  solution:
/*2016.3.5*/
#include<stdio.h>
#include<string.h>
int map[1050],mark[1050],n,m,h,l;
void dfs(int cnt)
{
	int i,j;
	if(cnt==(n-l)+1)
	{
		h++;
		if(h==m)//输出第m个排列 
		{
			for(i=1;i<n;i++)
			printf("%d ",map[i]);
			printf("%d\n",map[n]);
		}
		return ;
	}
	for(j=l;j<=n;j++)
	{
		if(!mark[j])
		{
			map[cnt+l]=j;
			mark[j]=1;
			dfs(cnt+1);
			mark[j]=0;
		}
	}
}
int main()
{
	int i,j,k;
	while(scanf("%d%d",&n,&m)==2)
	{
		if(n>=8)//当位数大于8时,取后8位即可 
		l=n-8+1;//l为后八位数中的首位数的下标 
		else
		l=1;
		h=0;
		for(i=1;i<=n;i++)
		map[i]=i;
		memset(mark,0,sizeof(mark));
		dfs(0);
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值