POJ-3187(Backward Digit Sums)(全排列+dfs())

19 篇文章 0 订阅

POJ-3187(Backward Digit Sums)(全排列+dfs())
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5706 Accepted: 3309

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample:

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

//注:这题主要考查全排列,把sum拆成n个连续数(排列顺序可能乱了)的和。利用全排列进行遍历,然后再对每一种排列情况进行处理,处理后经过判断当前组合是否满足题意。(若有多组解,选择把较小的数字放在前面的组合)(采用dfs()并且从小到大遍历排列,则当找到第一种满足题意的解时,输出,后续解全部舍弃。这就需要设置一个开关,在找到第一个解前,开关打开,当找到第一个解后把开关关闭。开关就是下面代码中的 l

My  solution:

/*2016.3.5*/

#include<stdio.h>
#include<string.h>
int map[20],mark[20],a[20],n,m,h,l;
void judge()
{
	int i,j;
	j=n;
	for(i=0;i<=n;i++)
	a[i]=map[i];
	while(j-1)//把n个数求和 
	{
		for(i=1;i<j;i++)
	    a[i]=a[i]+a[i+1];
	    a[j]=0;//循环一次,元素个数减1 ,减少的元素则赋值为0 
	    j--;//每循环一次,元素个数减1 
	}
	if(a[1]==m)
	{
		l=1;//开关关闭 
		for(i=1;i<=n;i++)
	    printf("%d ",map[i]);
	    printf("\n");
	}
	return ;
}
void dfs(int cnt)
{
	int i,j;
	if(cnt==n+1)
	{
		if(!l)//判断开关状态 
	    judge();
		return ;
	}
	for(j=1;j<=n;j++)
	{
		if(!mark[j])
		{
			map[cnt]=j;
			mark[j]=1;
			dfs(cnt+1);
			mark[j]=0;
		}
	}
}
int main()
{
	int i,j,k;
	while(scanf("%d%d",&n,&m)==2)
	{
		l=0;//初始化开关 
		map[0]=map[n+1]=0;
		memset(mark,0,sizeof(mark));
		dfs(1);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值