POJ - 3187 Backward Digit Sums(水+全排暴搜)

点击打开题目链接

Backward Digit Sums
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7311Accepted: 4221

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 
 
    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

给出第一行数的个数n,然后是第n行的数sum,输出第一行的排列。

思路,枚举1到n的全排列,直到找到一组数成立。

附上AC代码:

#include<bits/stdc++.h>

using namespace std;
int a[15],s[15];
int n,N,sum;

int main()
{
    cin>>n>>sum;
   
    for(int i=1;i<=n;i++)
       a[i]=i;
    do
    {
         for(int i=1;i<=n;i++)
            s[i]=a[i];
        for(int i=n;i>1;i--)
        for(int j=1;j<i;j++)
        {
            s[j]+=s[j+1];
        }
        if(s[1]==sum) break;
    }while(next_permutation(a+1,a+n+1));

    for(int i=1;i<n;i++)
        cout<<a[i]<<' ';
    cout<<a[n]<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值